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Downloading Exercise Files

Exercise files can be downloaded from the Cheryl Price web site as follows:

1 In your web browser, type: www.cherylprice.co.nz

2 Press Enter on the keyboard to display the Cheryl Price website.

Click in the Product Search box and type the number of this unit

. US 12885
3 standard, as shown at the right.

4 Click on

5 Click on US 12885

Under the Exercise Files heading click on the underlined blue hyperlink, ie
6 Book Exercise Files - V6 Word 2007 or 2010 Free bownload
The File Download dialog box will display.

7 If you have Winzip use the following instructions otherwise move to step 8.

a Click on .

b Clickonthe - ofthe button.

¢ If My Documents folder:is not displayed click on Set default unzip folder at the bottom
of the list. Ensure My Documents is selected then click on Select Folder.

d Click onthe = ofthe button and click on the My Documents folder. The files will
be unzipped.

8 Click on and ensure My Documents folder is displayed. Click on

Click on Open Folder which will display My Documents folder. Right click on the zipped
9 exercise file and select Extract All. Click on Extract. A folder will be created containing the
exercise files.




Changing Defaults

Default settings may have already been changed in your Word 2010 program. If not, you can use
the following instructions to change these.

Font and Font Size

You can check if the font and font size have been changed by looking at the Font box on the

Home tab. If it shows “eri®edi 10~ then jt has not been altered. Change the default font to

Arial 11 pt as follows:

1 Click on the Font Dialog Box Launcher Feont which will display the
Font dialog box.

2 Change the Font: to Arial and the Size: to 11 pt.

Click on Set As Default

4 Ensure the following option is selected for the font to be applied to All documents based on
the Normal template.

Microsoft Word @

Do you want to set the default font to (Default) Arial, 11 pt for:
@) This document only?
All documents based on the Normal template?

| K. ‘ [ Cancel

5 Click on OK then on OK from the Font dialog box.

Spacing

Click on the Page Layout tab and if 10 pt Spacing After is displayed as shown at the
right then this has not been altered. Remove 10 pt spacing as follows.

1  Click on the Paragraph Dialog Box Launcher Faragraph which will display the
Paragraph dialog box. Spacing
2 Change the Spacing After: to 0 pt-as shown at the right. E‘::re’ oet
After: 0pt

3 Click on |5Asesfault | Engyre All documents based on the Normal template is
selected then click on OK. Click on OK from the Paragraph dialog box.

Margins

Click on the Page Layout tab then click on the Page Setup Dialog Box Launcher
Page Setup which will display the Page Setup dialog box. If margins are
displayed as 3.17 cm change them as follows. (If they have been changed, click on Cancel.)

1  The Top: margin will be selected, ie ™ 33en =] Type: 2.54 then press the Tab
key. Repeat this until the margins are displayed as shown below.

Margins

Top: 2.54cm 2 Bottom: 2.54m
Left: 2.54cm 2 Right: 2.54m
Gutter: 0cm = Gutter position: Left IZ|

2 Click on |3#t8s8fut | Engyre All documents based on the Normal template is selected then
click on OK. Click on OK from the Paragraph dialog box.

ALk || A
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Unit Standard 12885 Version 6

Title Create and enhance electronic documents combining text and

images for generic text and information management

Level 2

Credits 4

Purpose

This unit standard is intended for people who input and
manipulate information using software applications to create
documents which communicate efficiently and effectively and
have visual appeal.

People credited with this unit standard are, for generic text and
information management, able to: create and manipulate text
and images to enhance electronic and printed documents; and
demonstrate knowledge of file saving protocols.

Classification

Business Administration > Text and Information Management -
Generic

Available grade

Achieved

Entry information

Recommended skills
and knowledge

Unit 12883, Enter and manage text for generic text and
information management, or demonstrate equivalent
knowledge and skills.

Explanatory notes

1 All activities associated with this unit standard must comply with Guidelines for
using computers: Preventing and managing discomfort, pain and injury,
(Wellington: Accident Compensation Corporation, Department of Labour, 2010),
available at http://www.osh.govt.nz/order/catalogue/computers.shtml.

2 Definitions

Design layout refers to the positioning and arrangement of various elements in a
document and considers contrast, repetition, alignment, proximity, harmony,
balance and proportion.



http://www.osh.govt.nz/order/catalogue/computers.shtml

Fit for purpose means the information is accurate and relevant to the intended
audience, and the document is free from text errors.

Intended audience is the individual or group who will receive the information,
therefore the amount and nature of the information and the level of the language
must be appropriate to this audience. The intended audience will be specified
for each document.

Visually balanced for the purposes of this unit standard means the sizing of text
and images is complementary.

Outcomes and evidence requirements

Outcome 1

Create and manipulate text and images to enhance electronic and printed documents.

Range

Evidence

11

1.2

1.3

the following text and information management features must be
demonstrated at least once over the three documents collectively —
importing and resizing an image; creating an image using draw or paint
tools; cropping a graphic; creating a drop cap; inserting a symbol or special
character; bullets and/or numbering; leader tabs; three different types of
set tabs;

evidence of three different documents is required.

requirements

Text and images are created and manipulated to produce documents that
are fit for purpose and the intended audience.

Placement of texts and images in the documents is visually balanced in
terms of design layout.

The printed documents are fit for purpose and the intended audience.

Outcome 2

Demonstrate knowledge of file saving protocols.

Evidence

2.1

2.2

2.3

2.4

requirements

An existing file is saved with a different file name in accordance with
standard operating procedures of the software.

An existing file is changed to PDF format in accordance with standard
operating procedures of the software.

An existing file is changed to a ‘read only’ file in accordance with standard
operating procedures of the software.

A document is saved in a different file format which is compatible with the
software being used.



Exercise Files used in this book

(Instructions are at the front of this book for downloading retrievable files from our web site.)

Names of files

Aerobic Competition

Italy

Appliances Jury Service
Barrier Reef Macroworks
Beads, Seeds and Shells Maori

California Motorhomes
China Mystery Weekends

Computer Wizz Limited

Paku Newsletter May 2012

Dining Out

Sea Shells

Elite Mystery Weekends

Send-a-Basket

Equipment SHOW JUMPING
Globe TravelCentre
Holland Vietnam

Hong Kong

Vi




The Word 2010 Screen
Create, Save, Open and Print Documents
1 Zoom and Document Views

Editing, Font and Font Formats

Section

Learning Outcomes

At the end of this section you should be able to -

0  Start and exit Word 2010

U Identify parts of the Word 2010 screen

0 Understand the Ribbon and groups

U Create, save, open, print and close documents

Q0  Spell and grammar check

O  Practise cursor movements

0 Use the Zoom feature and Document View options
0 Edit a document

0  Apply fonts and font formats

© Cherylprice.co.nz Limited SECTION1 1



Starting Microsoft Word

Exercise 1
1 Click on the Start button at the bottom left-hand corner of the screen.
2 Select|” AFrosrms from the Start Menu.

3 Select '+ Microsoft Office from the Programs menu.

Microsoft Word
2010 appears on
the Start menu after
you have used it
three times. You
can click on it to
start Word.

4 Select [W] Microsoft Word 2010 from the list to start Word 2010.

Microsoft Word will be displayed on screen with a new document, ready for you to enter text.

Quick Access Toolbar Tabs Title Bar Minimize Restore Down

‘ / / ‘ / \ / __—Close
File tab ~__ — Help
}» Ribbon

- 4 View
Group " Ruler

Insertion point _Vertical
Scroll Box

Rulers

Vertical
"~ Scroll Bar
Note:

If Rulers are not displayed click

on the View Ruler button at
the top of the Vertical Scroll Bar.

Select
__ Browse
Object

N v \T/ ~—
Status Bar Document Views

\ Zoom Controls

Note | The File tab which contains all basic tasks such as opening, saving and printing a
document has replaced the Office Button in Word 2007.

2 SECTION 1 © Cherylprice.co.nz Limited



Quick Access Toolbar

The Quick Access Toolbar contains commands to Save, Undo and Redo.
Frequently used commands can be added to this toolbar.

The Ribbon

The ribbon in Microsoft Word 2010 is divided into groups and used as described below. (The ribbon
replaces menus and toolbars that were used in Word 2003).

(@ When you click on a tab, groups will be displayed relating to that particular feature, eg the Home
tab displays the groups shown below, ie Clipboard, Font, Paragraph, Styles, Editing.

Tabs

Groups

(b) Clicking on a down arrow ~ displays options for that feature, eg

clicking on the down arrow at the right of Underline T in the Font
group displays underlining options as shown at the right.

(c) Clicking on the Dialog Box Launcher ' to the right of the group name
displays the relevant dialog box, from which you can also select the
same, and additional options, eg clicking on the Font Dialog Box
Launcher " displays the dialog box for that group as shown below.
(Click on Cancel to remove the dialog box.)

© Cherylprice.co.nz Limited SECTION1 3



Word Processing Basics

CtrI N

Ctrl S

Ctrl W

Creating a New Document

When you start Word a new document is automatically displayed on screen. When you have created,
saved and closed a document you create a new document as follows:

1 Clickon then on New. Blank document is selected in Backstage view
as shown at the right.

2 Clickon at the far right of the window.

Saving a document

Every document you create must be saved with a unique name (called the “file name”) so you can
recall it to the screen for editing, formatting or printing at a later time.

1  Click on the Save button = on the Quick Access Toolbar at the top left of your
screen. (Note: The Quick Access toolbar may be displayed under the ribbon.) Alternatively click
on the File tab then on Save.

2 Type a file name for your document. (Keep file names simple and relevant to the document. You
can use letters and numbers, hyphen and underscore.)

3 Clickon %< ] The file name is then displayed at the top of the screen.

Save As
1 Tosave a copy of a file open it then click on the tab.
2 Select [l savers type a new file name for the document then click on e

Closing a Document

When you have finished with a document you need to close it. If you haven’t saved any changes, you
will be prompted to do so (as shown at the right).

1  Click on the tab.

2 Click on [ Close,

3 Click on Save if asked to save the document.

Exercise 2

1 Inanew document type the following:

T yoo want to gqet fit and/or lose weight it is 4 qood ided to join @ qym. Look in yoor
local directory for the qyMs in yoor area. Often you can get a +rial membership for a
short peried, eq two weeks for a nominal ckarae. When yoo have decided on the qym
you wish to join yoo will be qjven a fitness test to ascertain your exercise proqram. I+
is important o attend reqolarly, at least three times a week, to qet Maxivom benetit.
Yoo will lock better and feel better after a short period of time.

2 Save the document with the file name of Getting Fit.
3 Close the document.

4 SECTION 1 © Cherylprice.co.nz Limited



Opening a document

A document is “opened” when you need to recall it to the
screen, eg for editing.

1 Click on . A list of Recent documents is
displayed in Backstage view as shown at the right.

2 Ifthe document required is listed click on it to open it.

cio  If the required document is not displayed on the Recent list click on [ Cpen, Click on the the
document required then click on OR double click on the file name.

Zoom

You can zoom in to get a closer view of your document or zoom out to see more of the page at a
reduced size. The Zoom controls on the Status Bar are located at the bottom right of your screen.

/ 100% (=) ? (+)
Zoom level Zoom Zoom Zoom

Out slider In

You will notice that the Zoom Slider is in the middle of the bar, ie at 100% view.

The Zoom controls are used as follows:
(a) Drag the Zoom Slider to the left to reduce the size of your document.
(b) Drag the Zoom Slider to the right to enlarge the size of your document.

OR

(@) Click on the Zoom Out button to reduce by increments of 10%.
(b) Click on the Zoom In button to enlarge by increments of 10%.

Additional Zoom options are available on the View tab as shown at the right.

Document Views

Microsoft Word 2010 has five different view options. These are available by using the Document
View buttons at the bottom right of your screen as shown at the left below, OR you can click on the
View tab which displays the same view buttons in the Document Views group at the left of the ribbon.

Print Layout /EI K
Draft
Web

Full Screen Outline
Reading Layout

Exercise 3

1 Open the document called Italy.

2  Look at the different zoom options.

3 Click on each of the document view buttons shown above.
4  Leave the document on your screen for the next exercise.

© Cherylprice.co.nz Limited SECTION1 5



Spelling and Grammar

Spell check is a useful facility which highlights incorrectly spelt words and suggests the correct
spelling. In Word 2010 possible errors are highlighted with underlining of the word(s) as shown
below.

Error Underline Example

Spelling Red line See you in teh morning.

Grammar Green line Lisa |ogk at the shoes in the window.
Context (when the word is spelled Blue line The system has it's own emergency
correctly but it is the wrong word for power source.

the context)

Position the cursor where spell checking is to commence.

1  Click on the Review tab, then click on the Spelling and Grammar button shown
at the right.

2  Select the word required from the Suggestions box, eg in the following example
you would accept the first selected option, ie cheaper

3 Clickon [ Gene= |

4 Click on OK when spelling and grammar checking has finished.

Automatic spelling and grammar check

Automatic spelling/grammar check puts a wiggly line under incorrect words that are not corrected, as
you type. Click the right mouse button on the incorrect word and select the correct option OR select
Spelling/Grammar to display the Spelling and Grammar dialog box.

Exercise 4

1 With the Italy document on screen check spelling and grammar. Correct any errors.

2  Save the document and leave on screen for the next exercise.

6 SECTION1 © Cherylprice.co.nz Limited



Find and Replace

Find Search Document box

The Find feature is used to locate a word or words in your document, usually

to edit or format text. When the Find feature is used the Navigation Pane is | Navigatien v
displayed at the left of your document and every occurrence of the word you | hotel x -
are searching for is displayed — an example is shown at the right. You can 12 matches
then click on the occurrence required. 55 -+
Find and Replace searching will start from where the cursor is positioned in off-season rates inmajor =
cities, thaugh some hotels in
your document. Rome, Florence, Milan and
other big

1 Onthe Home tab click on &3 Find * in the Editing group. . —
dve recognised oTr-seasons

The Navigation Pane is displayed at the left of your screen. L LE ZLSeE

considerable amount on
hotel rooms by visiting then,

2 Type the word or words that you are searching for in the Search

Document box then press Enter. and ties except at the
. . ) absolute top level hotel
Every occurrence of that word(s) will be displayed and the word(s) will | dining rooms and

restaurants. You don't need

be highlighted in your document.
3 Simply click on the occurrence required.

4 To turn off the Navigation Pane click on the Close button X

Replace

The Replace feature is used to replace a word or words with another word(s).

1 On the Home tab click on ®a=RePlac® i the Editing
group.

2 Inthe Find: box type the word(s) you wish to find and
in the Replace: box type the word(s) that are to be
replaced. An example is shown at the right.

3 Clickon to skip an occurrence, | Bepae=  [to
replace one occurrence or on to replace every occurrence.

4  Clickon when finished.
Note | The button is used to display additional find and replace options.

Exercise 5

3 In the Italy document find the words 6.30am then add a space between the time and am, eg
6.30 am. Change 12.15am in the same sentence in the same way.

Find railway station and change it to read railway and radio station...
Press Ctrl Home.

Replace towns with cities throughout the document.

~N oo o &~

Replace buys with bargains but only for the following occurrence, ie The best buys if you have a
shopping budget...

8  Save the document and leave on screen for the next exercise.
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Synonyms and Thesaurus

The Synonyms and Thesaurus features enable you to look up a word with the same meaning.

Exercise 6

1 Inthe Italy document right click on the word excursions in the first
paragraph.

2 Move the mouse pointer down to Synonyms. Similar words are
displayed as shown at the right.

3 Select trips which will replace the word excursions.
(If the Thesaurus option at the bottom of the Synonyms list is
selected, the Research task pane will be displayed at the right of
your document. You can then move the mouse pointer to the
required word, click on the arrow at the right and select Insert.
Click on x to close the Research task pane.)

shit F7 4 Using the Thesaurus, replace the word favourite (ie favourite city) on the second page with

another word that has a similar meaning.

5 Save the document.

Note | Clicking on the Review tab then on displays the Research task pane.

Proof-reading

Although the spelling and grammar facilities in Microsoft Word are excellent, and very useful, proof-
reading of your final document is still essential. Every document should be proof-read on completion
of edits and final spelling and grammar checking.

Exercise 7

1

Look at the following paragraph from the Italy document that you have just spell and grammar
checked (and learnt how to select a word with a similar meaning):

Part of the city’s centre is close to traffic; accept for those with permits, making things
easier for pedestrians. When looking for a particular places in Florence, be aware that
houses are numbered on a ‘double system’. Places with black (nero) numbers are
private dwellings and red (rosso) numbers refer to commercial buildings, such as shop.

Write down the grammatical errors that this paragraph contains, and the correct grammatical
options:

Read through the entire document correcting any errors that the Spelling and Grammar facility has
not corrected.

Save the document and leave it on screen.

Practise cursor movements shown on the next page.
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Cursor Movements

Cursor Position Mouse Keyboard Shortcut
A character at a time Move mouse and click Right — or Left «
A word at a time Move mouse and click Ctrl - or Ctrl «
Beginning of line Move mouse and click Home
End of line Move mouse and click End
A line at a time Move mouse and click Up® or Down {
Down one paragraph Move mouse and click ctrl
Up one paragraph Move mouse and click ctrl 1
Bottom of current window Move mouse and click Alt Ctrl Page Down
Top of current window Move mouse and click Alt Ctrl Page Up
Down one window Click below Vertical Scroll Box Page Down key
Up one window Click above Vertical Scroll Box Page Up key
Down one page * Clickon. ¥ at bottom right of screen Ctrl Page Down

* See below
Up one page * Clickon * at bottom right of screen Ctrl Page Up
Beginning of document & Sgitgi]ctzles\c/:?cﬁlic;;rsacgzllcklji?:)li to the top of the Ctrl Home

# See below -
crordoument | g e Vet ool o e otom of | g

Ctrl G

The mouse pointer shows as follows on the Microsoft Word screen.

1 The mouse pointer is displayed as an insertion point, sometimes called an 1-Beam when it is
within text. You can move the insertion point to the location required, then click the left
mouse button to set the cursor at that position.

L\\f The pointer changes to a left pointing arrow when it is moved to the scroll bars, Status Bar,
or to the top part of the screen.

The table below shows quick cursor movements for both the mouse and keyboard shortcuts.

The scroll wheel on the mouse can be used to quickly scroll through your document.

Go To

The Go To feature allows you to move to a specific page (or other location) in your document. Simply
press Ctrl G OR click on the page number shown on the Status Bar at the bottom of the screen, enter
the page number then click on Go To. Click on Close.

* Select Browse Object
If you cannot move up or down a page at a time click on the Select Browse Object button @ at the

bottom right corner of the Microsoft Word screen and select the Browse by Page option 1. When

you click on the # (Next Page) and % (Previous Page) buttons you will then be able to move a page
at a time through your document.
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# Vertical Scroll Box

The Vertical Scroll Box can be dragged up or down on the Vertical
Scroll Bar to display a page indicator. When you release the
mouse button the page will be displayed.

Status Bar

The Status Bar at the bottom left of the screen displays
information about the document on screen, ie the page you are
on, the number of pages, number of words and the dictionary used.

Previewing and Printing a Document

Ctrl P

The Print option on the File tab enables you to preview your document and then select options required
to print. Zoom options are available at the bottom right of the window and you can move to and from
pages using the page indicators in the bottom middle of the window.

1

2
3

Click on then click on Frint.

A preview of how your document will appear when printed is shown to the right in Backstage
view. This area is called Print Preview. (Print Preview was a separate feature in previous
versions of Word but is now incorporated into Backstage view in Word 2010.)

The options shown at the left can be selected from the Print All Pages button.

™~

Click on . The document will be sent to the printer.
Close the document.

Exercise 8

1
2
3
4

With the Italy document on screen click on the File tab then on Print.
In the Pages: box type 2 (to print page 2).

Click on the Print button.

Leave the document on screen for the next exercise.
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Selecting Text

Before you can delete, move, copy, or format text you must “select” it. Selecting text is sometimes
referred to as “highlighting”. This can be done in several ways but the most common method is simply
to hold down the left mouse button and drag across and/or down with the mouse.

The mouse changes to a right facing pointer when it is moved into the margin at the left of text. You
can select text (and/or graphics) by dragging down or up at the left, double click to select a paragraph
and triple click to select the whole document.

When you move the mouse to the left of a paragraph it displays as a right facing mouse
pointer. Text (and/or graphics) can then be selected by dragging upwards or downwards.
Clicking once the left of a paragraph will allow you selecta line, while a double click will
select a paragraph.

Mouse changes '
toarightfacing ——— ﬂ
pointer

The following methods can be used to select text using the mouse.

A character Click and drag across a character.

Aline Move the mouse pointer to the left of text and click.

A word Double click in a word.

A sentence Ctrl click anywhere in a sentence.

A paragraph Move the mouse pointer to the left of text. Point to the paragraph and

double click, OR triple click in the actual paragraph.

Multiple paragraphs With the mouse pointer positioned to the left of text, point to the first
paragraph anddouble click. Press the left mouse button and drag
downwards to select subsequent paragraphs.

Horizontally Click and drag across text.

Vertically Click and drag down with the insertion point OR drag at the left of text.

To select text between two Click at the beginning of the text to be selected. Move the insertion point to
points the end of the text. Hold down the Shift key and click.

Random selections Hold down the Ctrl key and select each group of text.

Ctrl A To select the whole document | Move the mouse pointer to the left of text then hold down the Ctrl key and
click OR triple click at the left of text OR press Ctrl A.

Deselect mouse-selected text Click away from the selected area or press any cursor key.

Exercise 9

1 With the Italy document on screen practise using the above methods to select text.
2  Save the document.
3 Leave the document on screen for the next exercise.
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Editing text

Ctrl Z

Ctrl Y

The techniques shown below are the most efficient methods of editing text, ie to correct errors or to
make alterations.

Basic Editing Summary

Editing Feature

Procedure

Insert text

Inserting is automatic. Click the insertion point where text is to be inserted and
type text.

Insert a blank line

Place cursor below the line to be inserted and press Enter.

Typing Replaces
Selection

Select text and type new text.

Delete to right of cursor

Press the Delete key. (Ctrl Delete deletes-a word to the right.)

Delete to left of cursor

Press the Backspace key. (Ctrl Backspace deletes a word to the left.)

Delete text

Select text and press Delete.

Delete a blank line

Place cursor on the blank line and press Delete.

New paragraph

Place cursor at the left of the beginning character of the intended new
paragraph and press Enter twice.

Join paragraphs

Place cursor at the end of the first paragraph and press Delete twice OR place
cursor at the beginning of the second paragraph and press Backspace twice.
Press the Spacebar twice.

Click on‘'the Undo button on the Quick Access Toolbar.

Undo last action 9
[ Click on the Redo button on the Quick Access Toolbar to redo the last “Undo”.
Redo last “Undo”
Exercise 10
1  With the Italy document on screen make the following edits:
a  Delete the second sentence, ie For example, if you visit ...
b Select August in the second paragraph and type July
c Atthe end of the second paragraph press the Delete key twice to join the third paragraph.
2  Practise other editing features shown above.
3  Close the document without saving.
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