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Downloading Exercise Files 
The exercise files listed on the following page can be downloaded from the Cheryl Price 
web site as follows: 
 

  

  

1 In your web browser, type: www.cherylprice.co.nz 

2 Press Enter on the keyboard to display the Cheryl Price website. 

3 
Click in the Product Search box and type the number of this unit 
standard, as shown at the right. 

4 Click on     

5 Click on   

6 

Under the Exercise Files heading click on the underlined blue hyperlink, ie     

Book Exercise Files - V6 Word 2010  Free Download 

The File Download dialog box will display.   

7 If you have Winzip use the following instructions otherwise move to step 8. 

a   Click on  .    

b   Click on the  of the  button. 

c  If My Documents folder is not displayed click on Set default unzip folder at the bottom 
of the list.  Ensure My Documents is selected then click on Select Folder. 

d    Click on the  of the  button and click on the My Documents folder.  The files 
will be unzipped. 

8 Click on and ensure My Documents folder is displayed.  Click on  

9 
Click on Open Folder which will display My Documents folder.  Right click on the zipped 
exercise file and select Extract All. Click on Extract.  A folder will be created containing the 
exercise files.   

US 12887 

US 12887 
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Exercise Files used in this book 
 

(Instructions are included on the previous page for downloading retrievable files  
from our web site at www.cherylprice.co.nz) 

 
 

Names of files 

Africa Herbs1 

Aroma Holland 

Barrier Reef Lifestyle Books 

BluePrint Catalog Lifestyle Books Budget 2012 

BluePrint Clients Data Lifestyle Books Letterhead 

BOF – Gilbert Letter Lifestyle Books Sales Summary  

Book Sales for 2011 Lilies 

Book Sales for 2011-Chart  Orchids 

Building Specifications Pool Tips 

Care of a New Puppy Rata Motor Camp Newsletter Nov 2014 

Clipper Cruises Rita Bay Golf Club 

Company List – 14 May W2010 Advanced 
Course Roses 

Contiki Sparkling Pools 

Directors Data Vegetables 

Eats and Treats Vitahealth Managers 

Eats and Treats Letter VitaHealth Sales 

Fiji Landing Apartments W2010 Advanced Course – 14 May 
Spreadsheet 

Herbs Wilson Markers 
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Unit Standard 12887 Version 6 
 

Title Integrate text and images and manage multiple files for generic text 
and information management 

Level 3 Credits 6 

 

Purpose This unit standard is intended for people who input and 
manipulate information using software applications to create 
documents which communicate efficiently and effectively and 
have visual appeal. 
 
People credited with this unit standard are, for generic text and 
information management, able to: integrate text and images to 
produce documents that are fit for purpose and the intended 
audience, and demonstrate file management techniques for 
multiple documents. 

 

Classification Business Administration > Text and Information Management - 
Generic 

 

Available grade Achieved 

 

Entry information 

Recommended skills 
and knowledge 

Unit 12883, Enter and manage text for generic text and 
information management, or demonstrate equivalent 
knowledge and skills. 

 
Explanatory notes 
 
1 Integration of text and images and demonstration of file management techniques 

in this standard must be applied in accordance with standard operating features 
of the software program being used by the candidate. 

 
2 All activities associated with this unit standard must comply with Guidelines for 

using computers: Preventing and managing discomfort, pain and injury, 
(Wellington: Accident Compensation Corporation, Department of Labour, 2010), 
available at http://www.osh.govt.nz/order/catalogue/computers.shtml. 
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3 Definitions 
 Design layout refers to the positioning and arrangement of various elements in a 

document and considers contrast, repetition, alignment, proximity, harmony, 
balance and proportion. 

 Fit for purpose means the information is accurate and relevant to the intended 
audience, and the document is free from text errors. 

 Intended audience is the individual or group who will receive the information, 
therefore the amount and nature of the information and the level of the language 
must be appropriate to this audience.  The intended audience will be specified 
for each document. 

 Integrate for the purposes of this unit standard means information is created in 
one application and revised and/or refined and/or reorganised using another 
related application. 

 
Outcomes and evidence requirements 
 
Outcome 1 
 
Integrate text and images to produce documents that are fit for purpose and the 
intended audience. 
 
Range documents may include but are not limited to – assignment, booklet, 

newspaper page, brochure, magazine page, children’s book; 
evidence of at least three documents is required. 

 
Evidence requirements 
 
1.1 Text and images are created using at least two different software 

applications.  
 

Range software applications may include but are not limited to – 
word processor, spreadsheet, database, graphics. 

 
1.2 The integration of the text and images supports the intent of the documents 

and the principles of design layout. 
 

Range may include but is not limited to - refining texts and images, 
formatting images, sizing, insert, grouping. 

 
1.3 A merge is created using at least five data fields for five database records, 

to insert variable information in a document. 
 

Range may include but is not limited to – customised labels, form 
letters. 
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Outcome 2 
 
Demonstrate file management techniques for multiple electronic documents. 
 
Evidence requirements 
 
2.1 Multiple directories or folders are created and used in accordance with 

standard procedures of the operating system. 
 
2.2 File management techniques are used to search for and locate a 

designated file in accordance with standard procedures of the operating 
system. 

 
2.3 A summary box containing relevant information is created to facilitate file 

retrieval in accordance with standard procedures of the operating system. 
 

Range includes – key words, author, comments. 
 
 

Planned review date 31 December 2015 

 
Status information and last date for assessment for superseded versions 
Process Version Date Last Date for Assessment 
Registration 1 22 December 1997 N/A 

Revision 2 16 January 2001 N/A 

Revision 3 13 November 2002 N/A 

Revision 4 19 September 2005 N/A 

Review 5 22 October 2010 N/A 

Revision 6 15 September 2011 N/A 
 
Consent and Moderation Requirements (CMR) reference 0113 
This CMR can be accessed at http://www.nzqa.govt.nz/framework/search/index.do. 
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Planning and Designing Documents 
Fonts, Page Layout 
Graphics, Borders and Shading 
File Management 

 
 
Learning Outcomes 
 
At the end of this section you should be able to -  
 

 Understand the principles of planning and designing documents 

 Understand the use of fonts and font styles 

 Insert and create graphics 

 Manipulate graphics to enhance design layout 

 Apply borders and shading 

 Use Document Properties for efficient file management 

 Locate files and folders stored on your computer 

 Search for files and folders using search features 

 Manage files and folders 

 Use printing options 

Section 
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2   SECTION 1 © Cherylprice.co.nz Limited 

Principles of Design Layout 

Positioning and arrangement of elements (text/images) on the page  
The way that text, graphics and any other enhancements are placed should aim to strike the right 
balance between repetition (to reinforce the similarities of related items) and variety (to sometimes 
break the pattern to create visual interest), so long as the following principles are adhered to. 

Contrast 
Items on the page that are different from each other should have enough contrast so that this difference 
is clear.  Headings should be of a sufficiently different format to contrast them with body text. 

Repetition 
Consistent formatting of the same kinds of items shows they are related, so the same formatting must 
be applied, eg to all subheadings and lists. 

Alignment 
Items should line up with related items.  Subheadings should be left-aligned above their respective text 
(centred subheadings may interfere with placement of graphics).  Items in a bulleted list must line up 
with each other.  Related paragraphs may have their alignment broken by graphics for visual interest, 
but not so much (ie by not more than one graphic) that their relationship to each other becomes lost. 

Proximity 
Items that belong together should be closer to each other than items that are separate.  A subheading 
should be closer to the text that it relates to than to other text.  The same is true of relevant graphics. 

Harmony  
Formatting and placement of items should work together as a cohesive whole.  Inconsistent spacing or 
formatting would not create a good harmony. 

Balance  
There must be a good use of white space so that items appear balanced on the page. 

Proportion  
Text, graphics or enhancements should be sized according to their importance.  Graphics should not 
overwhelm the text, for example, if they are only for general illustration or decoration.  A border 
should not be so large that it detracts from the text that it is supposed to enhance. 

Hint:   
Take a critical look at magazines and other documents and publications.  Take note of the following: 

 What is it about certain pages which you find appealing? 

 What is it about certain pages that you find you do not like? 

 What draws your eye to read a page? 
 

Please refer to the Appendix for additional layout information and Word quick reference notes.Note 
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Features that can enhance your work 
 
Most software applications have desktop publishing features that can be used to improve the overall 
appearance of your work.  Some of these features are listed below. 
 

Fonts 

Try to use no more than two different types of fonts in one 
document, eg Times Roman and Arial if you are 
displaying formal business documents.  You can still 
change the point size, add bold, italics, etc to the fonts but 
too many different fonts makes a document lose impact. 

Font sizes 

Choose a font size that can be read easily when it needs to 
stand out.  If you are creating a poster or advertisement 
you need to choose a size that will stand out and can be 
read at a distance.  If you are creating a personal document 
you do not need to use a really large font size for it to be 
readable. 

Font enhancements 

Use some of the following options to enhance the fonts in 
appropriate instances: 

Italics 
Bold 
Case options (ie uppercase, small caps, etc) 
Shadow, Outline etc (from the Font dialog box) 

Graphics 

Choose a graphic which is appropriate for the document 
and its purpose. 

Resize the graphic in proportion, ie do not lose the overall 
shape of the graphic when you are resizing. 

Place the graphic where it will enhance the document and 
give a “balanced” appearance. Consider -  is it better at the 
top right/left/centre or with text surrounding it further 
down the page?  Where will it have the most impact? 

Colour 
Remember that colour is not an advantage when you are 
printing in black and white.  Some items that look 
spectacular in colour on your display will be disappointing 
when printed in black and white. 

Lines, Borders, 
Shading etc 

Enhancements can be used such as lines, borders, shading, 
tables, page borders etc.  Line style, colour and thickness 
can be changed and fill added. 

White Space 

White space or blank space on a page is used to make the 
document easy to read.  White space makes design 
elements stand out and look effective.  Use it to add space 
around the edges of the document (margins) and to 
surround headings. 
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4   SECTION 1 © Cherylprice.co.nz Limited 

Layout and Design 
The first step is to plan your publication.  An eye-catching and appealing publication begins with 
planning and experimenting. 

Start planning a publication by sketching out, on paper, different layouts and ideas of the appearance 
you wish your publication to have.  Bear in mind the following principles of page layout: 

Balance Text, white space, graphics are placed to produce an 
attractive page. 

Harmony All items on the page work towards a common goal. 

Sequence The eye flows easily between the items on the page. 

Proportion Relative importance of each item is considered. 
 

Also consider the following: 
 Whom is this publication intended to attract? 
 What is your message? 
 What form is the publication going to take, eg book, brochure, flyer, magazine, etc 
 Is the content and style appropriate for your audience? 
 Are you consistent with your headings and text style? 
 Is there enough contrast and white space to add interest? 
 Does your publication look busy (crammed and not easy to read)? 
 
When sketching out your publication look at other publications, magazines, flyers and brochures.  
Ideas can be generated from glancing through different publications. The simplest design can be the 
most effective way to convey your message clearly and concisely.  
 
Look at the two publications below.  The publication on the left is an example of bad design and the 
one on the right is attractive and appealing, using desktop publishing features. 
 
 
 
 

 

Unbalanced (bad use of white space), 
eye does not flow easily between the 
items, heading needs more emphasis 

Balanced with clear flow down the page, 
items in proportion according to 
importance 

Clear Water Hotel
Sandra Street

Auckland

20 - 22 February 1999 

The Real Estate Club
22 Ross Estate Road, Auckland

Phone: 343 3458   Fax: 343 3459

Techniques in 
Real Estate

SEMINAR

Clear Water Hotel
Sandra Street

Auckland

20 - 22 February 1999 

The Real Estate Club
22 Ross Estate Road, Auckland

Phone: 343 3458   Fax: 343 3459

SEMINAR
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Other Planning Considerations 

Your planning sketch does not need to be detailed but should set out where the headings, graphics etc 
should be placed.  It may be altered once the document is more developed but it will give you a starting 
point. 
 
Consider the following: 

 Is there going to be a border? 

 Where will I utilize “white space”? 

 What font will I use for the main heading? 

 What font size will I use for the main heading? 

 Where will I align the main heading? 

 Will I use boxes, lines, shading, shadows, etc? 

 Where is the main text going to be placed? 

 How many graphics will I use? 

 Which graphics (if any) will I use? 

 Where are the graphics going to be placed? 

 What other effects can I use to make this eye-catching? 

 
 

Main heading 
 

photo 

Address/phone 
 

----------- 
----------- 
----------- 
----------- 

----------- 
----------- 
----------- 
----------- 

-----------------------------
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Tip 

 

Graphics  

General Instructions 
Drawing a Box/Circle/Rectangle/Square/Line 

1 Click on the Insert tab then on  which will display the options 
shown at the right. 

2 Click on the Rectangle button  (or other drawing tool).  Move the 
mouse pointer to the top left corner position where you wish to draw 
from. 

3 Click and drag the pointer diagonally, as shown below. 

 

Hold down the SHIFT key to draw an exact shape, eg square, circle. 

When the left mouse button is released the ‘object’ will have handles on it as shown below.  It can be 
resized by dragging on the appropriate “handles” (blue square boxes). (The green handle at the top 
allows you to rotate the object.) 

   
 
 
 
 
 
Hold down the Shift key while dragging a corner handle to resize proportionally. 
 

Selecting Object(s)  

• When selecting a single object click on an outside line. The mouse shows as . 

• To select several objects singularly, hold down the Shift key and click on each object when the 
mouse is displayed as a pointer with black cross. 

• To select several objects in a group, click on  then on Select Objects in the Editing group 
on the Home tab.  You can draw a selection box around the objects and when the left mouse 
button is released all the objects will be selected. 

• To turn off Select Mode press Esc. 
• To deselect an object(s) click on a blank area of the page. 

Moving Object(s) 

1 The object(s) must be selected (use the  button, Select Objects to draw around a group of 
objects). 

2 Place the mouse pointer on an object border, then drag to the new location. 

Holding down the Shift key when dragging an object, moves the object vertically and 
horizontally only. 

Lengthen 

Widen 

Widen and Lengthen 
Shorten or Lengthen 

Free Rotate handle 
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Changing the Line/Fill of an Object 
• Right click on the object then choose Format AutoShape to display the Format AutoShape dialog 

box. 

• Double clicking with the mouse pointer   on the object will display the Drawing Tools, Format 
tab on the ribbon where you can change the line style, shading etc.   

• You can also click on the object and select options on the Format tab. 
•  and   buttons can also be used. 
 

The drawing buttons default to single .75 pt line style, for rectangles, circles etc.  Shape Fill and Shape 
Outline styles can become the default (ie for every object that is drawn) by drawing an object and 
changing the line style and fill, right clicking and selecting Set as Default Shape. 

Creating a Text Box 

Several types of text boxes can be used in Word 2010.  The first one described below is a simple text 
box that you can format to your own requirements. 

• From the Insert tab, Text group, click on  then on .  Drag to form a text 
box.   

   

Text can be typed inside the box. The Text Box Tools, Format tab will display the above options you 
can use such as alignment, Text Box Styles, Shape Fill, etc.  The box can be resized, moved and the 
line style changed as for other objects.  A different font and font styles can be applied to selected text.  
The Internal margins of the text box can be changed by right clicking on the box, selecting Format 
Text Box and choosing the Text Box tab.   

Inserting Preformatted Text Boxes  

From the Insert tab click on  in the Text group.  Scroll down the list and click on a preset option.  
Type the text required into the preformatted text box then click outside the box.   

Horizontal Alignment 

Right click on the object and select Format AutoShape, Layout tab. In the Horizontal alignment section 
you can choose to align the graphic relative to the margins, either left, centre or right. 

Send to Back, Bring to Front  

The order of overlapped objects can be changed by using  or  in 
the Arrange group.  Click on  on one of these buttons and select the required option.  Alternatively 
you can right click on an object, choose Order then select the same options from the shortcut menu. 

Group/Ungroup 

Selected objects can be grouped together as one object or objects that have been grouped can be 
ungrouped.  Select the objects to be grouped then click on  from the Arrange group on the 
Drawing Tools, Format tab.  Alternatively, right click, select Group then Group. To ungroup objects 
use the same steps but select Ungroup. 
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Exercise 1 

 
1 Create a new document. 

2 Click on the Insert tab then on .  Click on the Oval shape  on the first row. 

3 Draw the following oval. 

 

 
 

 
4 Copying:  Ensure the oval is selected then hold down the Shift and Ctrl keys and drag to the right.  

The Ctrl key is used to copy the circle and the Shift key will ensure the copied circle is positioned 
exactly next to the original circle.  (The two ovals represent two feet.) 

 

 

 

 

 

5 Using the Oval tool draw the following representing toes. Hold down the Shift key while drawing 
for a perfect circle shape.  You can use the cursor keys (ie arrow keys) to move shapes. 

 

 

 

 

 

 

6 Grouping:  On the Home tab click on  then on .  
Using the mouse draw a selection box around the toes as shown at the right.  On 

the Drawing Tools, Format tab click on  then on .  This 
will make the toes one graphic which can be copied to the right foot. 

7 With the left foot toes selected hold down the Ctrl key and drag to the top of the right foot. 

8  Rotating:  On the Drawing Tools, Format tab click on .  Select  
then move the toes for the right foot so they are positioned as shown below.  
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9 Save the document with the file name of Shapes. 

10 Lines:  Draw a selection box around both feet and toes and group them OR hold 
down the Shift key and click on each object.  On the Drawing Tools, Format tab 
click on  and select a dark brown colour.  Click on 

 again then on Weight and select 1 pt.  

11 Fill:  With the shape selected click on  which will display the 
options below at the right.  You can select from colours, pictures, gradients, 
textures or patterns.  Click on then select the first texture shown.  
The Foreground colour can be changed as in our example below. 

 

12 Save the document. 

Saving a Drawing as a Graphic 
The easiest way to save a drawing that you have created in Word as a graphic file is to copy the image 
to the Clipboard, open the Paint program, paste the graphic and then save it. 
 
Exercise 2 

1 Select the feet that you have drawn and click on  on the Home tab. 

2 Click on the Start button  at the bottom left of your screen, select All Programs, Accessories 
then . 

3 In the Paint program click on  which will paste your image into Paint. 
4 If necessary drag the bottom right corner handle of the white frame until the outside frame is the 

same size as your image, as shown below. 

 

5 Click on  and move the mouse pointer down to .    
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Various file formats that you can save the image are shown at 
the right.  

6 Select  which is a standard 
graphic format. 

7 Ensure the Pictures Library folder is displayed then save the file 
with the file name of Feet. 

8 Click on  then on from Paint. 
 

Exercise 3 

1 In your Word document (ie Shapes) draw a rectangle as shown below, fill it with red colour then 
copy it twice as shown below.  Change the Shape Fill colour for the second and third boxes to 
green and blue. 

 

 

 

 

2 Click on the red rectangle then click on  on the Drawing Tools, Format tab. 

3 Click on blue rectangle then click on the  of   and click on .  
Practise options from these two buttons. 

Text Boxes 
Exercise 4 

1 Click on the Insert tab then on  then on .  Under the rectangles draw a text 
box as shown below.  Type your name and address in the text box and centre.  Drag on the 
“handles” to increase the size of the text box if necessary. 

 
 
 
 
2 With the text box selected change the Shape Fill to a pale grey and the Shape Outline to purple, 

1½ pt Weight.  Change the font to Arial 12 pt. 

The green circle at the top of the text box is used to rotate the text box. 

3 Practise drawing different shapes and text boxes and formatting them. 

To remove the border from a text box (or shape) click on  on the Text 
Box Tools, Format tab then on . 

4 Save the document and close. 
 

Exercise 5 

1 In a new document draw the shapes on the next page.  You may change the Shape Fill and Shape 
Outlines as desired. 

2 Save as Drawing Shapes and close. 

Cheryl Price 
PO Box 187 

Matakana  0948 

Note 
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Eau de Parfum Eau de Toilette Eau de Parfum 
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FOREVER 

Golden 
Sand 

Lemon 
and 
Lime 

Cool 
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Inserting Pictures 

• Pictures can be inserted into a document using  on the Insert tab. When you click on ClipArt 
the Clip Art Task Pane will appear at the right of the screen.  Click on the Results should be:  
and specify types of clip art that you want to search for.  If Include Office.com content is 
unchecked very few pictures will be displayed. Type a keyword in the Search for: box and click 
on Go to display a selection of clip art. 

• Click on  to display the Pictures subfolder under Libraries, which can be used to store clip art 
or graphics that are used frequently.  The Sample Pictures folder contains pictures you might like 
to use.  Click on the picture you require and click on the Insert button. 

• Pictures can be resized and moved to any location on the page.  (Double clicking on a picture 
displays the Picture Tools, Format tab shown below.) 

 

• Drag a corner handle to resize proportionally.   

• To “crop” a selected picture, use the  button on the Picture Tools, Format tab and drag on a 
crop handle.  Click on the Crop button again to confirm. 

 

Drop Caps 
he first letter of a paragraph can be automatically changed to a drop cap (ie to occupy 2-3 lines of 
text) by selecting the letter(s).  An example is shown at the beginning of this paragraph. 

Click on the Insert tab then on  and select an option from the list.  The Drop Cap displays a frame 
and can be moved, resized etc.  To remove a drop cap select the None option. 

 

WordArt 
WordArt enables you to enhance headings and text in a document by using special effects such as 
shadows, skewed, rotated and stretched text. 

Click on the Insert tab then on .  You can select from options shown below at the left.  After 
WordArt has been inserted you can click on the WordArt Tools, Format tab then on  
to display additional options as shown below at the right. 

 

T 
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