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Downloading Exercise Files 
Exercise files can be downloaded from the Cheryl Price web site as follows: 
 

  

 

1 In your web browser, type: www.cherylprice.co.nz 

2 Press Enter on the keyboard to display the Cheryl Price website. 

3 
Click in the Product Search box and type the number of this unit 
standard, as shown at the right. 

4 Click on     

5 Click on   

6 

Under the Exercise Files heading click on the underlined blue hyperlink, ie     

Book Exercise Files – V1 Excel 2010  Free Download 

The File Download dialog box will display.   

7 If you have Winzip use the following instructions otherwise move to step 8. 

 a   Click on  .    

 
b   Click on the  of the  button. 

 c  If My Documents folder is not displayed click on Set default unzip folder at the bottom 
of the list.  Ensure My Documents is selected then click on Select Folder. 

 d    Click on the  of the  button and click on the My Documents folder.  The files will 
be unzipped. 

8 Click on and ensure My Documents folder is displayed.  Click on  

9 
Click on Open Folder which will display My Documents folder.  Right click on the zipped 
exercise file and select Extract All. Click on Extract.  A folder will be created containing the 
exercise files.   

US 27643 
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Unit Standard 27643 Version 1 
 

Title Apply spreadsheet features to present data to meet a brief 

Level 4 Credits 6 

 

Purpose People credited with this unit standard are able to apply 
spreadsheet features to present data to meet a brief. 

 

Classification Business Administration > Business Information Management 

 

Available grade Achieved 

 
Explanatory notes 
 
1 Definition 
 Software help function includes all online or offline proprietary support and 

tutorials. 
 
2 Assessment against this unit standard must involve the candidate creating at 

least two workbooks and creating and formatting a minimum of three 
spreadsheets for each workbook.  The data to be presented should be 
contained in a brief provided to the candidate. 

 
3 Any commonly used proprietary or open-source spreadsheet software may used 

for assessment provided it includes the features, or their equivalents, specified 
in the range statements of outcome statement 1. 

 
Outcomes and evidence requirements 
 
Outcome 1 
 
Apply spreadsheet features to present data to meet a brief. 
 
Range features must include but are not limited to – conditional formatting, 

VLOOKUP, HLOOKUP, count, countif, round functions, links between 
sheets, links between workbooks, filters, hide data (rows and columns), 
nested formulae, tables, subtotals, named cells and ranges, mixed relative 
and absolute cell references, data validation, charts; 

 evidence is required of three different types of charts. 
 
Evidence requirements 
 
1.1 Features are applied to spreadsheet workbooks in accordance with 

computer textbooks and/or the software help function. 
 
1.2 Data are presented which meet the requirements of the brief.  
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Planned review date 31 December 2016 

 
Status information and last date for assessment for superseded versions 
Process Version Date Last Date for Assessment 
Registration 1 17 November 2011 N/A 
 
Consent and Moderation Requirements (CMR) reference 0113 
This CMR can be accessed at http://www.nzqa.govt.nz/framework/search/index.do. 
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Exercise Files used in this book 
 
(Instructions are at the front of this book for downloading retrievable files from our web site.) 

 
 

Names of files 

Active Sports Functions 

Albany Joinery for Charts Garden Soils Ltd 

Auckland, Jan-Mar Goodall Superannuation 

Balance Sheet Hats Income Statement 

Baxter Sports Jessie’s Clothing Stores 

Best Deals for Charts Learning Cheques 

Bonus Lifestyle Books 

Box Up Supermarkets Mid Semester Exam 

Brighton Winery Mountain Scene Sale 

Busy Bee Company Perfect Print 

Charts - Cleantec Rainbow Books 

Cleantec Recreational Magazines 

Computer Courses Sales Commission 

Cool Shot Photography Series 

Costello’s Fast Foods Spartacus - Adelaide 

Costello’s Product Sales Spartacus - Auckland 

Currency Rates Spartacus - Brisbane 

Cycle Stuff Sales - January Spartacus - Income Statements 

Data Tables Spartacus - Melbourne 

Day Tripper Spartacus - Sydney 

Eats and Treats Staff Listing 

Exclusive Services - Quarterly Report Te Kea Trading 

Fiji Landing Apartments VitaHealth Products 

Fire Shop - Brisbane Wellington, Jan-Mar 

Fire Shop - Melbourne Williams - Brisbane 

Fire Shop - Perth Williams - Cairns 

Fire Shop - Sydney Williams – Canberra 

Flower Shop Williams - Sydney 
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Naming Cells and Ranges  
Absolute Cell References 
Hide Columns and Rows 
Multiple Worksheets 
Charts Revision 

 
 
 
Learning Outcomes 
 
At the end of this section you should be able to -  
 
 
 Apply names to cell references and ranges 

 Use absolute cell references 

 Insert and edit headers and footers 

 Apply Cell Styles to a worksheet 

 Freeze panes 

 Hide columns and rows 

 Manage multiple worksheets (copy, move, delete, insert and link worksheets) 

 Create formulas across worksheets 

 Revise charts 
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Name box 

Naming Cells and Ranges 
A cell or a range of cells can be given a name which can be used instead of cell references.  Some 
advantages of using names are: 

• They are easier to understand than cell references. 
• They reduce the risk of using an incorrect cell reference in a formula. 
• They enable you to move quickly to an area within the worksheet. 
• They can be used to reference across worksheets. 

Defining a Name 
Exercise 1 

In this exercise, names will be assigned to the columns in a worksheet containing figures.  These 
names will then be used when creating Sum and Average functions. 

Names cannot contain spaces or symbols. 

1 Open the workbook called Te Kea Trading.  Ensure that the Pricing 
Structure sheet is active. 

2 Select the cell range B7 through B14. 

3 Click in the Name box at the left of the Formula bar (which 
presently displays B7). 

4 Type: cost 

5 Press Enter. 

6 Define names for the following ranges. 
retail C7:C14 
margin D7:D14 
quantity E7:E14 

7 An alternative method of creating cell names is to use the 
Define Name dialog box. 

a Select the range F7:F14. 

b Click on the Formulas tab. Click on . The New Name dialog box appears. 

c In the Name: text box type: value 

 
d Click on OK. 

  

Note 
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Create Names 
Columns or rows of cells can be given names derived from the column 
or row headers. In the next exercise Product names will be assigned to 
each row of numbers. 

Exercise 2 

1 Select the cell range A7:G14. 

2 On the Formulas tab, click on .  Ensure Left column is selected. 

3 Click on OK. 

4 Click on the Name box  and the names will display as shown at the right. 
Notice that the characters that cannot be used in names (space and ‘) have been 
replaced by the underscore character. 

5 Click on a name to select the cells that have been assigned that name. 
 

Using a Name in a Formula 
Exercise 3 

1 In cell B16, type: =sum(cost)and press Ctrl Enter. 

2 Format cell B16 to Currency. 

The Total Cost displays the result $767.00 and the Formula bar shows the entry as 
=SUM(cost). 

3 Click on cell C16. 

4 Type: =sum(retail) and press Ctrl Enter. 

5 Format cell C16 to Currency. 
 
Exercise 4 

Calculate the Total %Margin as follows. 

1 Click on cell D16 and type: =(C16-B16)/C16 

2 Press Ctrl Enter. 

3 Ensure cell D16 is formatted to Percentage with two decimal places. 

4 Click on cell E16 and type: =sum(quantity) and press Tab. 

5 In cell F16 type: =sum(value) and press Ctrl Enter. 

6 Format F16 to Currency. 
 

Using a Name in the Formula Palette 
In the following exercise you will create a function to calculate the average of the %Margin 
column. 

Exercise 5 

1 Click on cell A18 and type: Average Margin and bold it. 
2 In cell B18 click on  of  and select Average.   

3 Type: margin to replace the highlighted cell range within the function’s brackets. 

Sa
m

pl
e D

oc
um

en
t



4    SECTION 1 © Cherylprice.co.nz Limited 

 

4 Press Ctrl Enter. 

5 Format to Percentage with two decimal places. The average margin result displays as 33.62%.  

6 Press Ctrl Home (to return to cell A1). 
 

Using a Name with Go To 
Names can be used to move quickly to a designated area of your worksheet.   

Exercise 6 

1 Click on  and then select  

The Go To dialog box displays a list of all names in the 
worksheet, and all past cell references that have been used. 

(Alternatively a named range can be selected from the Name 
Box .  Past cell references will not be listed.) 

2 Double click on retail.  Cells C7 to C14 will be selected. 

3 Press Ctrl G.  Type: F16 in the Reference: text box, and 
click on OK. 

4 Save the workbook as Named Ranges and close it. 
 

Deleting Names 

1 With the workbook open click on the Formulas tab. Click on . The Name Manager 
dialog box will be displayed. 

2 Select the name to be deleted. 

3 Click on . 

4 Click on OK.  
  

Ctrl G 
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Series 
The Series command is used to fill a range of cells with a 
sequence of values.  This is useful to quickly insert numbers, 
(eg from 1 to 10), or consecutive dates. 

A series range starts with a number or date value and 
increases by a set step value until a stop cell or stop value is 
reached.  A series can be entered by using the fill handle OR 
by clicking on in the Editing group on the Home tab, 
and choosing Series. 
 

Series in Select Rows to fill the series across selected rows, or select Columns to fill down 
selected columns. 

Type Select the type of series required. 

Date unit If Date is selected in the Type section, the date increments by Day, Weekday, Month 
or Year, depending on what is selected in the Date unit section. 

Step value: The amount by which a series is increased or decreased.  A positive number will 
increase a series and a negative number will decrease a series. 

Stop value: The value that completes a series. 
 

Fill Series Options 
 
Description Instruction 

To insert incremented number 
values 

1 Select the number value cells. 
2 Hold down the Ctrl key and drag on the fill handle. 

To define step units, ie the 
increment amount 

1 Select the value cells and the range to be filled. 

2 Choose , Series. 
3 Select the type of fill required. 
4 Click in the Step value: box and enter a value. 
5 Click on OK. 

To define stop units, ie the final 
amount 

1 Select the first cell. 

2 Choose , Series. 
3 Select the type of fill required. 
4 Click in the Stop value: box and enter a value. 
5 Click on OK. 

To insert incremented dates 1 Select the cell containing the first date. 
2 Click and drag on the fill handle. 

To fill cell(s) with the contents of the 
cell(s) to the left 

1 Select the cell(s) with data.   
2 Hold down the Ctrl key and select empty cells to the right.   
3 Press Ctrl R (Copy to the right). 

To fill cell(s) with the contents of the 
cell(s) above 

1 Select the cell(s) with data.   
2 Hold down the Ctrl key and select the empty cells below.   
3 Press Ctrl D (Copy down). 
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Exercise 7 

1 Open the workbook called Series. 

2 In cell A7 type: 1000 and press Ctrl Enter. 

You will insert a series of numbers that starts at 1000 and increases by two into cells A7 to 
A14. 

3 Select cells A7 to A14.   

4 From the Home tab, choose  then click on Series and type: 
2 in the Step value: box as shown at the right. 

5 Click on OK.   

6 In cell B5, type: 31 May and press Ctrl Enter. 

7 Select cells B5 to F5.  Choose  then click on Series.   
Date is automatically selected in the Type section.  Select the Month option from the Date 
unit section, and click on OK. 

8 Type the data shown below. Select the cell(s) in each row, then drag the fill handle across to 
column G. 

 
 

 
 

Using the Shortcut Menu 
The shortcut menu can also be used to fill cells. 

Exercise 8 

1 In cell A26 type: Monday as the first entry, and press Ctrl Enter. 

2 Using the right mouse button drag the fill handle across to cell 
G26.  When the mouse button is released the shortcut menu 
shown at the right will be displayed. 

3 Select Fill Weekdays. 

4 Save and close the workbook. 

  

Fills cells with the characters 
CF and increments the 
numbers, eg CF101, CF102 

Fills cells with the names of 
each month 

Fills cells with the value 
2000 

Fills cells with the word Week 
and increments the number, 
eg Week 1, Week 2 

Fills cells in increments of the 
difference between the two 
selected cells 

Fills cells with the text from 
the selected cells 
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Absolute Cell References 
A cell reference in a formula that changes when the formula is copied is called a “relative” 
reference. 

An “absolute” reference is a reference to a specific cell or group of cells in a worksheet.  It does 
not change when a formula that refers to it is copied to another area within the worksheet, ie the 
cell reference is “fixed”. 

An absolute reference is indicated by adding a $ as a prefix to the column and/or row number that 
is to remain fixed.  This can be entered manually or by pressing the F4 key on the keyboard.  To 
change a cell reference to absolute, click on the cell reference (either in the Formula Bar or in the 
cell while editing), then press F4.   

Mixed references are a combination of absolute and relative cell references, eg $C12 (absolute 
column reference = C, relative row reference = 12). 

F4 toggles through the combinations of absolute, relative and mixed references. 

Relative  B6 
Absolute $B$6 (Press F4) 
Absolute column and Relative row (mixed) $B6 (Press F4 again) 
Relative column and Absolute row (mixed) B$6 (Press F4 again) 

 

Exercise 9 

An absolute cell reference is used in this exercise to calculate the Amount by multiplying No. of 
Students by the Course Cost.  If the Course Cost changes, only the figure in cell B6 will need to be 
updated as every copy of the formula will refer to it absolutely. 

1 Open the workbook called Computer Courses. 

 

2 In cell C11 type: = 

3 Click on cell B11 then type: * 
4 Click on cell B6.  The formula in cell C11 will read =B11*B6.  Press Ctrl Enter. 

5 Click and drag the fill handle down to cell C15.   
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6 Notice that the results for the last four courses are incorrect - this is because the 
“relative” cell reference B6 has been copied as B7, B8, and B9.  Click on cell C14 
and look at the formula.  It refers to cell B9 rather than B6. 

7 Select cells C12 to C15.  Press the Delete key.  You will now make the reference 
to B6 absolute in the formula in cell C11. This means that the reference to B6 will 
not change when the formula is copied down the column. 

8 Click on cell C11.  Click at the end of the formula on the Formula Bar and press 
F4.  The formula will now read =B11*$B$6.  Press Ctrl Enter. 

9 Drag the fill handle down to cell C15 – the formula has now been copied correctly. 

10 In cell C17 total cells C11 to C15. 
 

% Total 

An absolute reference must also be used when calculating what percentage of a total is represented 
by each of the numbers included in that total.  

In the worksheet below, the total of the Amount column equals 100% of all course fees.  The last 
column shows the percentage of each course, eg the $221,850 for Word 2010 is 28.62% of 
$775,170.   

 

Exercise 10 

To find the percentage total of the Word 2010 course, the amount in cell C11 ($221,850) is divided 
by the total amount in cell C17 ($775.170). 

1 Click on cell D11 then type: = 

2 Click on cell C11 then type: / 
3 Click on cell C17, then press F4 which will make the reference to cell C17 absolute. 

4 Press Ctrl Enter. 0.28619529 is displayed in the cell. 

5 Use the fill handle to copy the formula down to cell D17. 

6 Format cells D11 to D17 to display % as follows: 
a With cells D11 to D17 still selected click on the Percent Style button  in the Number 

group on the Home tab.  

b Click on the Increase Decimal button  twice to display two decimal places. 

7 Delete the 0.00% in cell D16.   

8 Click on cell D15 then click on .  Click on cell D17 and the formatting will 
be copied.  Ensure cells C17 and D17 display Top and Double Bottom Border lines. 

9 Change the Course Cost in cell B6 to $475, press Ctrl Enter and notice how the Amount 
figures change. 

10 Save and close the workbook. 
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Exercise 11 

1 In a new workbook create the worksheet shown below.  

 

2 In cell B11 create an absolute reference formula =A11*$B$4 to calculate Gross (remember to 
use F4 to make B4 absolute), and copy it down to cell B18. 

3 In cell C11 enter the formula =B11*$B$6 (Gross *Discount %) to calculate the Discount 
amount.  Copy it down the column. 

4 Enter a formula in cell D11 to calculate the Net cost and copy it down to D18. Widen 
columns as necessary.  Format cells B11 to D11with $ symbol.   

5 Make changes as follows. 
• Increase the price of the product to $140. 
• Decrease the discount to 10%. 

You will see the changes in the worksheet.  Apply formatting as shown below. 

 

6 Save the workbook as Star Toner and close it.   
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Exercise 12 

This exercise requires the use of mixed absolute and relative references to ensure that the formulas 
can be correctly copied to other cells.  You will calculate New Zealand currency converted to 
Australian currency. 

1 Open the workbook called Currency Rates and click on cell B9. 

2 Type: = then click on cell B8 (ie the amount to be converted). 

3 Type: * then click on cell A9 (ie the Exchange Rate of 94%).  Press Ctrl Enter. 

4 With cell B9 selected, drag on the fill handle across to cell G9.  Widen the columns to display 
the formula results. Note that the copied results are incorrect.  The formula in cell C9 refers to 
cell B9, instead of cell A9, and the same problem has occurred in each of the copied formulas. 

5 Click on the Undo button  until only the original formula in cell B9 remains. 

To be able to accurately copy this formula to the rest of the table, the formula in cell B9 needs 
to be modified to mixed absolute and relative cell references. 

6 Edit the formula in cell B9 to =B$8*$A9.  Press Ctrl Enter. 

This will ensure that when you copy the formula across to G9 the reference to A9 will not 
change.   

Similarly, when you copy the formula down to row 16 the references to the Spending 
Allowance numbers in each column will not change.  In other words, column A (containing 
the exchange rates) and row 8 (containing the spending allowance) will remain fixed 
(absolute). 

Use the fill handle to copy the formula across to cell G9, then copy down to cell G16.   

7 Select some of the cells to see how the formulas have been appropriately changed. 

 

8 Save and close the workbook.   

=B$8*$A9 
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Freeze Panes 
Many sheets are too large to be viewed completely on your screen.  The Freeze Panes option 
makes working with large worksheets simpler by locking rows and columns so they remain visible 
when scrolling down or across your worksheet. 
 
Exercise 13 

1 Open the workbook called Costello’s Product Sales. 

2 Type January in C5 and drag the fill handle across to I5 to insert the months January to July. 

3 In cell A7 type the product code 1001.   

4 Hold down the Ctrl key and drag the fill handle down to cell A22 to increment the data by 1, 
ie 1001, 1002, 1003, etc. 

5 Format cells A7 to A22 as Text. 

6 Select cells C7 to J24 and click on . The totals will appear in the last selected 
row and column. 

7 Click on cell B7.   

8 Click on the View tab. 

9 Click on .  Choose . 

10 Click on the  at the bottom of the vertical scroll bar to move down the worksheet.  Notice 
that rows 6 and above remain fixed. 

11 Click on the  at the right of the horizontal scroll bar to move to the right of the worksheet.  
Notice that column A does not move as it is frozen. 

 

12 Click on .  Choose . 

13 Save the workbook. 
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Hide Columns and Rows 
Columns and rows can be hidden within a worksheet.  This feature enables you to print only the 
data that is displayed on the screen (omitting columns and rows that are hidden).  You may choose 
to unhide columns or rows at any time. 
 

Hide Columns 
Exercise 14 

1 Select columns C to I. 

2 Click on  in the Cells group on the Home tab. 

3 Choose Hide & Unhide then choose Hide Columns as shown 
at the right.  

Alternatively, right click on a selected column header and 
select Hide.  The columns selected will be hidden. 

4 View the worksheet using Print Preview.  The columns that 
have been hidden will not display or print.   

5 Close Print Preview. 
 

Unhide Columns 
Exercise 15 

1 Select columns B to J. 

2 Click on  on the Home tab. 

3 Choose Hide & Unhide then choose Unhide Columns. 

Alternatively, right click on a selected column header and select Unhide.  The worksheet will 
expand to display the columns that were hidden. 

4 View the worksheet using Print Preview.    

5 Close Print Preview. 
 

Rows 

• Rows can also be hidden by selecting the row(s) you wish to hide and choosing , Hide & 
Unhide, Hide Rows. 

• Unhide rows by selecting the rows above and below the hidden row(s) and choosing , 
Hide & Unhide, Unhide Rows. 
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