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Downloading Exercise Files 
The exercise files listed on the following page can be downloaded from the Cheryl Price web 
site as follows: 
 

  

 

1 In your web browser, type: www.cherylprice.co.nz 

2 Press Enter on the keyboard to display the Cheryl Price website. 

3 
Click in the Product Search box and type the number of this unit 
standard, as shown at the right. 

4 Click on     

5 Click on   

6 

Under the Exercise Files heading click on the underlined blue hyperlink, ie     

Book Exercise Files –  v7 Access 2010 Free Download 
The File Download dialog box will display.   

7 If you have Winzip use the following instructions otherwise move to step 8. 

a   Click on  .    

b   Click on the  of the  button. 

c  If My Documents folder is not displayed click on Set default unzip folder at the bottom 
of the list.  Ensure My Documents is selected then click on Select Folder. 

d    Click on the  of the  button and click on the My Documents folder.  The files 
will be unzipped. 

8 
Click on then click on the Documents folder 
shown at the right..   

Click on  

9 Click on   which will display My Documents folder.  Right click on the 
zipped exercise file and select Extract All. Click on Extract.  A folder will be created 
containing the exercise files. Delete the Compressed (zipped) Folder. 

US 2786 

US 2786 
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Changing Defaults 
Default settings may have already been changed in your Word 2010 program to those displayed 
on page 13.  If not, you can use the following instructions to change these. 

Font and Font Size 
You can check if the font and font size have been changed by looking  at the Font box on the 
Home tab.  If it shows  then it has not been altered.  Change the default font to 
Times New Roman 12 pt as follows: 

1 Click on the Font Dialog Box Launcher  which will display the 
Font dialog box. 

2 Change the Font: to Times New Roman and the Size: to 12 pt. 

3 Click on . 

4 Ensure the following option is selected for the font to be applied to All documents based on 

the Normal template.  

 
5 Click on OK then on OK from the Font dialog box. 
 

Spacing 
Click on the Page Layout tab and if 10 pt Spacing After is displayed as shown at the 
right then this has not been altered.  Remove 10 pt spacing as follows. 

1 Click on the Paragraph Dialog Box Launcher  which will display the 
Paragraph dialog box.   

2 Change the Spacing After: to 0 pt as shown at the right.  

3 Click on .  Ensure All documents based on the Normal template is 
selected then click on OK.  Click on OK from the Paragraph dialog box. 

Margins 
Click on the Page Layout tab then click on the Page Setup Dialog Box Launcher 

 which will display the Page Setup dialog box.  If margins are 
displayed as 3.17 cm change them as follows.  (If they have been changed, click on Cancel.) 

1 The Top: margin will be selected, ie .  Type:  2.54 then press the Tab 
key.  Repeat this until the margins are displayed as shown below. 

. 

2 Click on .  Ensure All documents based on the Normal template is selected then 
click on OK.  Click on OK from the Paragraph dialog box. 
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NZQA Outcomes and Evidence Requirements 
 

Unit Standard 2786 Version 7 
 

Title Create and use a computer database to solve a problem 

Level 2 Credits 3 

 

Purpose People credited with this unit standard are able to plan, create 
and use a computer database to solve a problem, using a 
supplied brief. 

 

Classification Computing > Generic Computing 

 

Available grade Achieved 

 
Explanatory notes 
 
1 The supplied brief must clearly identify the problem and the outcomes required 

from the solution.  The brief must contain requirements against which the 
success or otherwise of the database can be evaluated. 

 
2 A plan outlines how the requirements of the brief will be realised.  For this unit 

standard, the plan may be informal, and it may be more appropriate to produce 
evidence of it during task completion rather than prior to starting the task or 
project.  Evidence of planning may be oral, written, and/or graphic. 

 
3 Definition 

Data type is the type of data stored in a field.  Data types at this level must 
include text and number fields. 

 
4 Legislation relevant to this unit standard includes but is not limited to the: 

Copyright Act 1994: 
Copyright (New Technologies) Amendment Act 2008: 
and any subsequent amendments. 

 
5 An assessment resource to support computing unit standards (levels 1 to 4) can 

be found on the NZQA website at www.nzqa.govt.nz/asm. 
A specific resource and assessment task for assessing against unit standard 
2786 and ‘The Computing Process - a clarification document’ can be found on 
the NZQA website. 
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Outcomes and evidence requirements 
 
 
Outcome 1 
Plan a computer database to solve a problem using a supplied brief. 
 
Evidence requirements 
1.1 A database model is selected to meet the requirements of the brief. 
 

Range may include but is not limited to – flatfile, hierarchical, 
relational, network, or a combination of models. 

 
1.2 The plan identifies the purpose, specifications and/or features required for 

the database in accordance with the brief. 
 
 
Outcome 2 
Create a computer database to solve a problem using a supplied brief. 
 
Evidence requirements 
2.1 Database fields are created and properties managed according to the 

database model and to meet the specifications of the plan. 
 

Range field properties include but are not limited to – size, data type 
and format. 

 
2.2 Test records are created and copies are checked against the properties of 

the database fields. 
 

Range accuracy, readability, presentation, data integrity. 
 
 
Outcome 3 
Use the computer database to provide a solution to the problem. 
 
Evidence requirements 
3.1 Database records are managed to provide the solution to the problem and 

meet the requirements of the brief. 
 

Range new records added, records deleted, record fields updated. 
 
3.2 Data integrity practices are demonstrated in terms of comparison with 

original information sources in order to ensure the solution to the problem 
has been met. 

 
3.3 Database records are sorted to provide the solution to the problem and 

meet the requirements of the brief. 
 

Range includes but is not limited to – alphabetically, numerically. 
 
3.4 Queries are applied to database in order to find data occurrences as 

required by the brief. 
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Planned review date 31 December 2016 

 
Status information and last date for assessment for superseded versions 
Process Version Date Last Date for Assessment 
Registration 1 30 September 1994 31 December 2013 
Review 2 24 September 1997 31 December 2013 
Revision 3 28 July 1998 31 December 2013 
Review 4 30 July 2002 31 December 2013 
Revision 5 16 July 2004 31 December 2013 
Review 6 22 May 2009 31 December 2015 
Rollover and 
Revision 7 19 September 2013 N/A 

 
Consent and Moderation Requirements (CMR) reference 0226 

This CMR can be accessed at http://www.nzqa.govt.nz/framework/search/index.do. 
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Exercise Files used in this book 
 
(Instructions are at the front of this book for downloading retrievable files from our web site.) 
 
 

Names of files 

Database Plan 

Friends Database 

MovieMaker Database 

Student Database 

Wedding Database 
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Database Theory 
Entering Simple Data 
Field Types 

 
 
 
 

 

Learning Outcomes 
 
At the end of this section you should be able to -  
 
 
 Understand database concepts and the uses of databases 

 Understand the different types of databases 

 Start Access 2010 

 Open an existing database 

 Understand the database window and database objects 

 Open a database table 

 Identify parts of a table 

 Navigate through records in a table 

 Manipulate data in a table by filtering and sorting records 

 Add a new record to a table 

 Delete a record from a table 

 Close a database table 

 Close a database 

 Exit Access 2010 

Section 

1 
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What is a Database?   
A database is an organised collection of information on a specific subject.  We use databases all 
the time in everyday life – the telephone directory, for example, is a database. 

Other examples of databases are: 

 Recipe book 

 List of employee details (start date, name, address, date of birth, salary) 

 List of CD collection (name of CD, date of release, artist/band) 

 Stock listing (product name, number of stock, supplier, type of product) 

 Library (where all the books are categorised and then stored alphabetically within the 
category making them easy to find) 

The data in an Access 2010 database is stored in one or more tables.  A table is made up of 
records, and records are made up of fields.  In a Customers table, a record could be: 

Smith Jane 319 Alfred St East Sydney NSW 2010 (02) 9955 2523 

The fields could be called: 

Surname FirstName Street Suburb State PostCode PhoneNumber 

 

Uses of Databases 
Databases hold information.  This information can be searched and selected. 

For example: 

 A telephone directory is used to search for the telephone number of a person whose name is 
known to you.  You already know the contents of the Surname field, and usually the 
FirstName field – these are your search criteria. 

 The search criteria are then used to look up the additional information about the person – ie 
to find the particular record and therefore the address and telephone number of the person. 

 If you only know one criterion value (eg the Surname), you will find many more matching 
records than if you know more criteria (eg the Surname, FirstName and StreetAddress). 

 

Advantages of Databases 
Databases are designed to store large amounts of data.   They allow you to control the way the data 
is organised and displayed. 

Once the required information has been stored in a database, it can be used in many ways.  For 
example, you can format and print it as a report.  Charts can also be created using information in 
the database. 

Other examples of database programs are Lotus Approach, DataEase, and Dbase IV. 
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Different Types of Databases Models 
There are several different types of Database Models: Flat File, Relational, Hierarchical, and 
Network models.  Each is briefly described here. 
 
Flat File Data Model (Single Table)  

This data model stores data in a single table in rows and columns.  There are no links to any other 
sources of data. Data stored in a single Excel spreadsheet is an example of a flat file database. 

If only one table is used for a database all data will be stored in and accessed from that table.  This 
is an example of a Flat File Database. 

Clients’ Pet Visits 
ClientID Title FirstName LastName Address PetName PetType VisitDate Reason 
Andrw1 Mrs  Judy  Andrews 2 Ocean View Rd Lassie dog 30/11/2005 Injury 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Matthew cat 22/11/2005 Illness 
Robbn1 Dr Jonathan  Robbins 122 Crowley Court Tippy bird 19/11/2005 Illness 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Jennifer bird 18/11/2005 Injury 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Matthew cat 11/11/2005 Routine 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Matthew cat 03/11/2005 Illness 
Andrw1 Mrs  Judy  Andrews 2 Ocean View Rd Zachary dog 02/11/2005 Illness 

 
You will notice that data duplication occurs in this Flat File Data Model.  For example:  

a) Mr Bill Evans‟s name and address appears in each of his records. 
b) He has two pets, a cat and a bird and has visited the Vet several times with these pets. 

Their names and types are also duplicated. 

Data duplication is a problem with the Flat File Data Model, and when the same data is entered 
repeatedly the chances of it being entered incorrectly increases. 

Relational Data Model (Multiple Tables) 

Data in this model is stored in multiple tables, each on a specific subject.  Sometimes you will 
want to combine data from two or more tables, and this requires that Relationships are created 
between them. 

If we took the single table example above and converted it into a relational database, we would 
split the data into three separate tables.  This would remove the problem of duplication of data. 

The diagram below shows an example of relationships between tables. 
 Clients Visits Pets 
 

 

 

 

 
The tables would appear as shown on the following page.  Each table is storing data on a specific 
topic.  The tables are related by a common field: Clients and Visits by ClientID, and Pets and 
Visits by PetID. 

PetID 
PetName 
PetType 
PetGender 

ClientID 
PetID 
VisitDate 
Reason 
Treatment 

ClientID 
Title 
FirstName 
LastName 
Address 
Suburb 
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Clients Table 

ClientID Title FirstName LastName Address Suburb 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Takapuna 
Andrw1 Mrs  Judy  Andrews 2 Ocean View Rd Torbay 
Robbn1 Dr Jonathan  Robbins 122 Crowley Court Epsom 

Pets Table 
PetID PetName PetType PetGender 
1 Jennifer bird F 
2 Matthew cat M 
3 Lassie dog F 
4 Zachary dog M 
5 Tippy bird F 

Visits Table 
ClientID PetID VisitDate Reason Treatment 
Evans1 1 18/11/2005 Injury Bandage leg 
Evans1 2 03/11/2005 Illness Medication for cat fever 
Evans1 2 11/11/2005 Routine Full examination, no problems 
Evans1 2 22/11/2005 Illness Under observation 
Andrw1 3 30/11/2005 Injury Operation 
Andrw1 4 02/11/2005 Illness Injection for diarrhoea 
Robbn1 5 19/11/2005 Illness Ointment 

 
Hierarchical Data Model (Tree-like Structure)  

The Hierarchical model is organised in a tree-like structure.  This means it allows repeating 
information in the data that uses parent/child relationships.  A parent/child relationship means that 
each parent may have many children but each child will only have one parent. 

Hierarchical Model Example 

 

 

 

 

 

 
If we were to use this on the Client and Pets example the Client is the Parent and the Pet is the 
Child.  Under a Hierarchical structure One Client may have many Pets, but each Pet may only 
have One Client (Owner). 
 
Network Data Model (Tree-like Structure)  

The Network Model uses objects and their relationships in a more flexible way.  The important 
thing about a Network Model is it is viewed as a graph using object types which are referred to as 
nodes, and relationship types which are referred to as arcs.   

When you compare the hierarchical model with the tree structure (which has one parent and many 
children records) this model gives the flexibility of having multiple parent and child records which 
make up a graph type of structure.   

This model was used widely in the early years of computing.  However, as computer processing 
became faster, people began using the Relational Model in preference to the Network Data 
models. 

Client/Pets is Parent/Child  
(One Client/Many Pets) 

Pets/Visits is Parent/Child 
(One Pet/Many Visits) 

Client (Parent) 

Pets 

Visits 

Vet 

Operations 
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Starting Access 2010 
Exercise 1 

 Click on the Start button , and click on All Programs.  Click on Microsoft Office and 
then on Microsoft Access 2010. 

 

The full name of the application is Microsoft Office Access 2010 but for the rest of this book it 
will be referred to as Access 2010. 
 

When you have used Access 2010 a few times it will appear on your Start menu as shown 
below.  You can just click on it to start Access. Click on the arrow to the right of it to see a 
list of recently used Access databases. 

 

Note 
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The Microsoft Access Backstage View 

 

 
 
 

File Tab  
The File Tab displays a drop-down menu which gives easy access to Access 2010 commands, ie 
New, Open, Save, Save As, Print. 

Quick Access Toolbar 
The Quick Access Toolbar is a useful feature for keeping all of your most frequently used 
commands in easy reach.   

Available Templates Window 
The Available Templates window is displayed when Access 2010 is first opened.  It displays a list 
of templates available to use when creating a new database.  These will already have all the fields 
set up in the tables so that it is easy to add data to your new database.  Some templates are loaded 
in Access 2010, and others can be downloaded from Microsoft‟s web site.   
 

Title Bar 
When a database is open its name appears on the window title bar.  (Because a database is not 
open in the above illustration there is no file name showing.) 

Minimize, Maximize and Restore Down 
These two buttons are used to increase (maximise) the size of the main window (Access 2010) and 
reduce the main window to a button (minimise) on the Taskbar.  When the window is maximised, 
the Maximize button will display as the Restore Down button.  

Close 

Restore Down Minimize 

Microsoft 
Office 
Access Help 
(F1) 

File Tab 

Title Bar 

No 
database 

is open 

Available 
Templates 

  window 

Quick Access 
Toolbar 
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Close    
This is used to close Access 2010. 

Microsoft Office Access Help (F1) 
This displays a list of Help topics in the „Microsoft Office Access Help (F1)‟ window.  You can 
also type a question into the „Type words to search for‟ box and search for a help topic.  When 
Enter is pressed a list of help topics relating to the question will appear. 

Exercise 2 

 With   selected in the Available Templates section click on  at the bottom 
right of the window. 

 

Using the Quick Access Toolbar 
The Quick Access Toolbar is a useful feature for keeping all of your most 
frequently used commands in easy reach.  Commands can be added or 
removed and the toolbar itself can be positioned either above or below the 
Ribbon. 

Quick Access Toolbar List 
Exercise 3 

1 Click on the Customize Quick Access Toolbar button  to the right 
of the Quick Access Toolbar.  A menu of commands will display.  A 
tick is shown to the left of every command that is currently on the 
Quick Access Toolbar. 

2 Click on the New command to add it to the Quick Access Toolbar. 

3 Click on the  again and click on the Open command. 

4 Add the following commands to the Quick Access Toolbar using the 
same steps. 

Quick Print, Print Preview, Spelling  

Customise Quick Access Toolbar 
Some other useful commands are not on the Quick Access Toolbar list, but these can be added 
using the following steps. 

Exercise 4 

1 Click on the  to the right of the Quick Access Toolbar and select More Commands… 
 

The Access Options dialog box will display, with the Quick Access Toolbar option selected 
as shown on the next page.  
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You could also click on the File Tab, click on , then select Customize. 

2 Click on the Choose Commands from:  and select All Commands.  The commands are 
listed in alphabetical order. 

3 Scroll down the list until the Close commands are displayed.  

4 Click on  then click on . 

5 Click on  then click on . 

The two commands will be added to the Quick Access Toolbar 
list as shown on the right. 

6 Click in the following option to display the Quick Access 

Toolbar below the Ribbon  

7 Click on OK to close the Access Options dialog box.  

You can click on the  of the Quick Access Toolbar and select Show Above the 
Ribbon or Show Below the Ribbon at any time.  

8 Ensure the Quick Access Toolbar is displayed above the Ribbon. 

 

The commands that you have just added in the two previous exercises will be used 
throughout this book. 

9 Click on the Close Database button on the Quick Access Toolbar as 
shown at the right. 

Note 
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Opening a Database 
Exercise 5 

1 From the File Tab menu click on  to open an existing database.  

The Open dialog box will display existing database files (they may be in another folder). 

 
Open Dialog Box 

2 Click on the MovieMaker Database. 

3 Click on . 

Access 2010 has improved security measures to protect your PC from viruses.  Many 
database files contain shortcut programs called macros that are designed to help the user work 
more efficiently.  A macro could also be a virus however, and Access 2010 may try to warn 
you about this.  

Unless your security settings are already set to the lowest level, Access 2010 may display the 
following security warning when you click on Open. 

 
 

4 Click on .  The Moviemaker Database is clear of viruses.  The database is 
now enabled so it can be accessed. 

 

Security Settings 
Security settings can be changed from High to Medium or Low but we recommend that you 
continue enabling content when you open a database instead of changing the security as this could 
be hazardous to your computer.   

It is your responsibility to look after the security of your computer by using and maintaining up to 
date anti-virus software.   
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MovieMaker Database 

The database that has been opened is a simple flat file database designed to keep track of videos in 
a video shop. 

The MovieMaker Database can be used as follows: 

 To search for specific videos 

 To find a specific type of video, eg action, romance, comedy 

 To see in how many videos the lead role is played by a specific actor or actress 

 To search for a specific director 

 To see if a video is in the shop or on lease 

 
 

Using the File Tab 
The File tab is located at the top left of the screen.   

 

Exercise 6 

1 Click on . 

A menu with commands for working with your files will display, eg to open a database, create 
a new one, or to save or print the file you are working on. 

 

Recent Documents 

The menu includes the Recent command.  Select this to display a list of the databases that you 
have been working on most recently.  Click on a database name to open it.  (Recently used 
databases are also listed on the File tab above the Info option.) 

If you haven‟t used Access 2010 before, the Recent Documents list will be empty. 
 

Command Options 

Some commands have options that you can select from.  Click on the menu item to display 
them, eg Print as shown on the next page. 

Sa
m

pl
e D

oc
um

en
t



12   SECTION 1 © Cherylprice.co.nz Limited 

 

The Print options shown here allow you to choose between Print, for selecting printing 
options, Quick Print, to send the whole document straight to your default printer, and Print 
Preview. 

The Save Database As command displays the Save As dialog box. 

 
 

Closing a Database 

If you want to keep Access 2010 open for other work, use the Close Database button you 
added to the Quick Access Toolbar, or the  button on the File tab menu to 
close the database you are working on. 

 
2   Closing Backstage View 

Press Esc to close Backstage View. 
 

Access 2010 

You can click on the Close button  at the top right of the screen to close Access 2010. 
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