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Downloading Exercise Files 
Exercise files can be downloaded from the Cheryl Price web site as follows: 
 

  

  

1 In your web browser, type: www.cherylprice.co.nz 

2 Press Enter on the keyboard to display the Cheryl Price website. 

3 
Click in the Product Search box and type the number of 
this unit standard, as shown at the right. 

4 Click on     

5 Click on   

6 
Under the Exercise Files heading click on the underlined blue hyperlink, ie     
Book Exercise Files – V4 Excel 2010  Free Download 
The File Download dialog box will display.   

7 If you have Winzip use the following instructions otherwise move to step 8. 

 a   Click on  .    

 
b   Click on the  of the  button. 

 
c If My Documents folder is not displayed click on Set default unzip folder at the 

bottom of the list.  Ensure My Documents is selected then click on Select 
Folder. 

 d Click on the  of the  button and click on the My Documents folder.   
The files will be unzipped. 

8 
Click on  then click on the Documents 
folder shown at the right. 

Click on  

9 
Click on Open Folder which will display My Documents folder.  Right click on the 
zipped exercise file and select Extract All. Click on Extract.  A folder will be created 
containing the exercise files.   

US 18743 

US 18743 
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Exercise Files used in this book 
 
(Instructions are included on the previous page for downloading retrievable files from 

our web site at www.cherylprice.co.nz.) 
 
 

Name of files 

Clarkson Contractors 

Hemana Stationery Supplies  

Sandi’s Budget 

Sandi’s Budget for Charts 

The Corner Dairy 
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NZQA Outcomes and Evidence Requirements 

 
Unit Standard 18743 (Version 4) 

 
 

Title Produce a spreadsheet from instructions using supplied 
data 

Level 1 Credits 2 

 

Purpose People credited with this unit standard are able to produce a 
spreadsheet from instructions using supplied data. 

 

Classification Computing > Generic Computing 

 

Available grade Achieved 

 
 
Explanatory notes 
 
1 Candidates are required to produce and print a spreadsheet using supplied data 

and instructions that specify the formatting, graphic, and print layout 
requirements, and where the formulae should be placed in the spreadsheet. 

 
2 Legislation relevant to this unit standard includes but is not limited to the: 

Copyright Act 1994 
Copyright (New Technologies) Amendment Act 2008 
Health and Safety in Employment Act 1992, 
Privacy Act 1993; 
and any subsequent amendments. 

 
3 An assessment resource to support computing unit standards (levels 1 to 4) can 

be found on the NZQA website at www.nzqa.govt.nz/asm.   
‘The Computing Process - a clarification document’ contains further information 
and can be found on the NZQA website. 
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Outcomes and evidence requirements 
 
Outcome 1 
 
Produce a spreadsheet from instructions using supplied data. 
 
Evidence requirements 
 
1.1 Data is entered into the spreadsheet, using labels and values, in 

accordance with instructions. 
 
1.2 Data is formatted in accordance with instructions. 
 
1.3 Spreadsheet cell functions and/or formulae are used in accordance with 

the instructions. 
 

Range includes but is not limited to – add, subtract, multiply, divide, 
sum. 

 
1.4 Two different types of graphs are produced from spreadsheet cell ranges 

in accordance with instructions. 
 
1.5 The spreadsheet and graphs are printed in accordance with the layout 

requirements of the instructions. 
 
 

Planned review date 31 December 2016 

 
Status information and last date for assessment for superseded versions 
Process Version Date Last Date for Assessment 
Registration 1 30 July 2002 31 December 2013 

Revision 2 16 July 2004 31 December 2013 

Review 3 22 May 2009 31 December 2015 

Rollover and 
Revision 4 19 September 2013 N/A 

 
Consent and Moderation Requirements (CMR) reference 0226 

 
This CMR can be accessed at http://www.nzqa.govt.nz/framework/search/index.do. 
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© Cherylprice.co.nz Limited SECTION 1     1 

 
 
 

What is a Spreadsheet? 
The Excel 2010 Screen 
Open a Workbook 
Add Data to a Workbook 

 
 

 
Learning Outcomes 
 
At the end of this section you should be able to -  
 
 

 Understand spreadsheets 

 Identify elements of a spreadsheet 

 Start Excel 2010 

 Move around the workbook window 

 Understand rows, columns and cells 

 Open a workbook 

 Identify labels, values and formula 

 Add data to a workbook 

 Save a workbook 

 Print a worksheet 

 Close a workbook 
  

Section 

1 
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2    SECTION 1  Cherylprice.co.nz Limited 

Spreadsheets 
A spreadsheet is essentially a large chart composed entirely of rectangular 
spaces (called cells).  A spreadsheet is made up of rows and columns.  The 
data that is entered into cells can be stored as values, text, numbers or 
formulas. 

Excel 2010 (or any spreadsheet program) makes calculations easy - it replaces your pencil, paper 
and calculator.  If you change data in a worksheet, every formula associated with that data will be 
automatically recalculated accordingly.  Data can be altered to calculate budgets and to forecast 
results.  Worksheets can be saved on disk, retrieved and printed as required. 

Charts can be created in a variety of different styles to show data in visual form. When spreadsheet 
data is changed, the information in the chart is updated and vice versa. 
 
 
Spreadsheets are widely used - 

1 In industry and commerce for 

 - financial accounts 
 - forecasting and projection results 
 - recording and comparing data 
 - personnel details 
 
2 At home for 

 - budgeting 
 - calculations, eg painting, wallpapering 
 - savings and travelling expenses 
 
3 At schools for 

 - test and examination results 
 - timetables 
 - school rolls 
 
4 At clubs for 

 - membership fees 
 - sports results 
 - sponsorship details 

Examples of other spreadsheet programs are Lotus 1-2-3, Corel Quattro Pro, SuperCalc. 
 

Working with Spreadsheets 
In a spreadsheet program cell references are used and not the actual numbers to calculate what is 
contained in the cells (ie the intersection of a column and a row).  If the actual numbers are changed 
then the calculations (referred to as formulas) will update.   
  

Sa
m

pl
e D

oc
um

en
t



© Cherylprice.co.nz Limited SECTION 1     3 

Manual versus Computerised Spreadsheets 
Before spreadsheet software programs, calculations were made on grid paper.  To 
give you an understanding of how this relates to a spreadsheet, our example below 
shows each column indicated by an alphabetical letter and each row by a number.  
The characters used to identify each column are referred to as “column headings”.  
The numbers used to identify each row are referred to as “row headings”.  The 

intersection of a column and row is referred to as a “cell”, eg cell A1 contains the text Michael’s 
Budget, cell B8 contains the total of cells B5, B6 and B7.  An example of a basic manual spreadsheet 
is shown below with data written onto the grid.  
 

Elements of a Spreadsheet 
 A B C D E 

1      
2      
3      
4  April May June Total 
5 Bus Fares 35.00 32.00 38.50 105.5 
6 Entertainment 20.00 15.00 25.00 60 
7 Haircuts 12.00 12.00 12.00 36 
8 Total $67.00 $59.00 $75.50 $201.5 
9      

The figures from each column would be added on a calculator and the total written into the Total 
row at the bottom of each column.  You might also need to calculate each row across and insert the 
total amount in the Total column.  The Total in cell E8 would then be the same whether added down 
column E, or across row 8 (ie it is a double check).  The above spreadsheet would display in Excel 
as shown below. 

 
 
Labels 
Labels are text or numbers that are not used in a mathematical formula or equation.  They help the 
reader understand different parts of a worksheet, ie column headings, row headings, title of a 
worksheet, etc. 
 
Values 
Values are data that is used to calculate results or the end result of a calculation. 

Reference to particular data is described by the use of cell references to show how an amount is 
calculated, eg the Total Bus Fares figure of $105.50 would be shown in an electronic spreadsheet as 
a formula, =SUM(B5:D5) which simply means to add the contents of cells B5+C5+D5.  If one of 
the figures is changed, the formula will update automatically because cell references are used to 
calculate and not actual figures. 
  

Michael’s Budget 
April-June Labels  

Values  

Column  
Heading 

Row 
Heading 
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4    SECTION 1  Cherylprice.co.nz Limited 

Samples of Spreadsheets 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Advantages of Spreadsheets 
 Calculations can be performed quickly and easily. 

 Figures can be quickly calculated and if data is altered the calculations automatically adjust. 

 Worksheets within a workbook can be used for different groups of data.  Data from a group of 
worksheets can be calculated onto one summary worksheet. 

 Charts can be used to visually display data - bar, column, pie, line. 

 Data can be manipulated, grouped and sorted into a specific order for lists, databases, etc.  Data 
within a spreadsheet can then be quickly located. 
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© Cherylprice.co.nz Limited SECTION 1     5 

 

Starting Excel 2010 
Exercise 1 

1 Click on the Start button   at the bottom left-hand corner of the screen.    

2 Select   from the Start menu.  

3 Select  from the Programs menu. 

 

4 Click on   from the list to start Excel 2010.  
 
 

The Excel Screen 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Office button  in Excel 2007 has been replaced with a File tab   which 
contains all basic tasks such as opening, saving and printing a spreadsheet. 

 

Active cell 

Name 
Box 

Column heading 

Vertical 
scroll bar 

Sheet tabs 

Title Bar Quick Access Toolbar Minimize 
Close 

Microsoft 
Excel Help 

Status Bar 

Ribbon 
 

Horizontal 
scroll bar 

Row 
heading 

Restore Down 

Note 

Formula Bar 

Tabs 
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6    SECTION 1  Cherylprice.co.nz Limited 

Quick Access Toolbar  
The Quick Access Toolbar contains commands to Save, Undo and Redo.  
Frequently used commands can be added to this menu.   
 

The Ribbon 
The toolbars and menus from Excel 2003 were replaced by the ribbon in Excel 2007 and is very 
similar in Excel 2010.  The ribbon provides access to all the tools required for working with a 
spreadsheet.   

 
 

 

Ribbon Tabs 
The ribbon has a series of tabs along the top; click on the tab to display the ribbon required.  There 
are seven default tabs: 

 

Exercise 2 

1 Position the mouse pointer on the Insert tab.  Click on it.  

The displayed buttons will change accordingly as shown below.  

 

2 Click on the Home tab. 

3 Position the mouse pointer on the Cut button  on the Home tab. (On your screen this 
button may not display the word “Cut”).   

A short description of the button is shown in a small box below the ribbon together with the 
shortcut key for that feature, ie Ctrl X.  

 

4 Move along other buttons on the Home tab to view their descriptions.   
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© Cherylprice.co.nz Limited SECTION 1     7 

The File tab 

The File tab  is located at the top left corner of the screen. It enables access to the common 
tasks for all Microsoft Office programs such as New, Open, Save and Print. 
 
Exercise 3 

1 Click on the File tab   
 

2 Click on the different options at the left.  At the right relevant details relating to that option will 
be displayed.  The Recent option is shown below. 

 

 
 

3 Click again on the File tab to remove the File menu. 

There are also hidden tabs that appear when appropriate, such as the Chart Tools.   These are 
displayed when you are working on a chart and disappear again when you have finished.   

 

 

 

Groups 
Ribbons are split into groups, (eg the Font Group).  Each group contains command buttons 
appropriate to a particular action; the font formatting tools are located in the Font Group. 

 

 
 

Clipboard 
Group 

Font 
Group 

Alignment 
Group 

Cells  
Group 

Editing 
Group 

Styles 
Group 

Number 
Group 
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Dialog Box Launcher 
The Dialog Box Launcher is the small diagonal arrow in the bottom right corner of some groups.  
When you click on this button, it displays an associated dialog box.   

Dialog boxes usually contain more settings or advanced features.  For example, the Number dialog 
box allows you to make formatting changes to the contents of the current cell, or selected cells. 
 

 
 

 
 

 
 

Close Window/Close Excel 
Used to close the current workbook or shut down Excel 2010.  

Exercise 4 

1 Click on the Close Window button  at the top right of the screen.  If you are asked to save 
changes click on No. 

2 Click on the Close button  on the Title bar to close Excel 
OR 

3 Click on the File tab  and select . 
 

Each time you start Excel a blank worksheet will be displayed.  If you close a 
worksheet when in Excel and want to create another worksheet you need to click 
on the File tab, ensure Blank workbook is selected (as shown at the right) then 

click on . 

 

Close 

Close 
Window 

Note 

Ctrl N  
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© Cherylprice.co.nz Limited SECTION 1     9 

The Excel Worksheet 
The Excel worksheet is the computer equivalent of a paper ledger sheet.  It is made up 
of a grid consisting of columns and rows.  This worksheet environment can make 
working with numbers easy. 
 

 
 
Column and Row Headings 
Exercise 5 

1 Ensure a new blank worksheet is displayed. 
2 Move the mouse pointer to display next to the A in column A. 
3 Click and column A will be selected as shown at the right. 
4 Move the mouse pointer to column D.  Click on the column heading D to select that column. 
5 Move the mouse pointer to display next to the 1 in the first row (ie row 1).  
6 Click and row 1 will be selected as shown at the right. 
7 Move the mouse pointer to the row 5 heading and click to select the row. 
 

Cells 
Remember that the intersection of a row and column is a called a cell.  Each cell is assigned a unique 
address according to the column letter and the row number.  For example, the cell in the far upper 
left corner is named cell A1 (column A, row 1). 

 
 

Name Box 
The Name Box is located at the top left corner of the worksheet, immediately below the ribbon.  
When Excel is started it will show the current location as cell A1.   
Exercise 6 

1 Click on cell A1. 

2 Move the mouse pointer to the cell at the right of cell A1 and 
click.  The Name Box will display the name of the cell as B1. 

3 Move the mouse pointer down a cell and click.  The Name Box will display B2.   

4 Move the mouse pointer to the left of the current cell and click.  The Name Box will display A2. 

5 Click on cell A1 and look at the Name Box to ensure you are in the correct cell. 

Rows 

Columns 

Name Box 

Cell A1 

Name Box 
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Formula Bar 
The Formula Bar is located on the same line as the Name Box.  It displays the contents of the cell 
and is used to edit data. 

 
Exercise 7 

1 Type: Cell which displays the text in the Formula Bar. 

2 Move the mouse pointer to the Enter button  on the Formula Bar and click.  The text will 
be entered into cell A1. 

3 Click on B1 and type: Column  

4 Move the mouse pointer to the Cancel button  on the Formula Bar and click.  The text will 
be deleted from the Formula Bar and not entered into cell B1. 

 
Status Bar 
The Status Bar is located at the bottom of the worksheet.  It shows the current condition of the 
worksheet - it shows as Ready indicating that the worksheet is ready to accept instructions.   

 

 

 
 
Exercise 8 

1 In cell B1 type: Column  The condition of the Status Bar will change to Enter.   

2 Press Enter and the condition of the Status Bar will change to Ready.  
 

Formula Bar 

Vertical 
Scroll bar 

Horizontal 
Scroll bar 

Scroll Up Arrow 

Scroll Down 
Arrow 

Scroll box 

Scroll Right 
Arrow 

Status Bar Scroll Left 
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© Cherylprice.co.nz Limited SECTION 1     11 

Scroll Bars (vertical and horizontal) 
These are vertical and horizontal bars with arrows used to scroll through a worksheet using the 
mouse. 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise 9 

1 Click once on the Scroll Down Arrow  at the bottom of the vertical scroll bar.  You will be 
moved down a row.   

2 Click three more times and row 5 will now display as the first row in the worksheet. 
3 Click on the Scroll Up Arrow  until row 1 is shown.   

4 Click on the Scroll Right arrow  five times to move across the worksheet. 
5 Click on the Scroll Left arrow  five times to move back to display the first column in the 

worksheet. 

 

 
 

The Scroll box is used to scroll through a worksheet quickly and indicates the position within a 
worksheet.  It also enables you to move to a specific page. 

 
 

Scroll box 

Horizontal 
Scroll bar 

Scroll box 

Vertical 
Scroll bar 

Scroll Down Arrow 

Scroll Up Arrow 

Scroll Left 
Arrow 

Scroll Right 
Arrow Sa
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12    SECTION 1  Cherylprice.co.nz Limited 

The Workbook 
A workbook is a single file in Excel.  In each new workbook there are worksheets.  By default an 
Excel workbook will have three blank worksheets.  Worksheets are named as Sheet1, Sheet2, etc.  
Worksheets are designed to display different data, eg a company might use a worksheet for each 
sales branch, then a final worksheet which totals all sales figures from each branch and displays a 
summary. 

Sheet tabs are displayed at the bottom of the screen.  You can move from worksheet to worksheet 
by clicking on each sheet tab OR by using the Tab Scroll buttons, as displayed below. 

 
 
 
 

 
 

 

 
 

 

Each sheet tab can contain a break down of different 
areas/costings, etc within a workbook.  A summary of the 
sheet tabs is often displayed on the first or last sheet tab. 

Summary 

Sheet tabs 
Active worksheet  
(displayed on screen) 

Tab Scroll 
buttons 

Sydney 

Christchurch 

Auckland 
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