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Downloading Exercise Files 
Exercise files can be downloaded from the Cheryl Price web site as follows: 
 

 
 

1 In your web browser, type: www.cherylprice.co.nz 

2 Press Enter on the keyboard to display the Cheryl Price website. 

3 Click on the Resources tab as shown at the right. 

4 Click on  Easy Way – Microsoft Access 2010   

5 

Click on the Free download hyperlink, ie   

Access 2010, Level 2    Free Download 
The File Download dialog box will display.   

6 If you have Winzip use the following instructions otherwise move to step 7. 

 a   Click on  .    

 
b   Click on the  of the  button. 

 c  If My Documents folder is not displayed click on Set default unzip folder at the bottom of 
the list.  Ensure My Documents is selected then click on Select Folder . 

 d    Click on the  of the  button and click on the My Documents folder.  The files will 
be unzipped. 

7 Click on and ensure My Documents folder is displayed.  Click on  

8 

Click on Open Folder which will display My Documents folder.  Right click on the zipped 
exercise file and select Extract All. Click on Extract.  A folder will be created containing the 
exercise files.   

You will need to double click on this folder to use the exercise files in this book. 
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Exercise Files used in this book 

 
(Instructions are at the front of this book for downloading retrievable files from our web site.) 
 
 

Names of files 

Care Cosmetics Staff Fresh Products Database 

Coronation Road Book Store MovieMaker Database 

Database Documents Southfield Mall Tenants 

Deep Blue Dive Club  
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Database Theory 
Entering Simple Data 
Field Types 

 

 

 
Learning Outcomes 
 
At the end of this section you should be able to -  
 
 
 Understand database concepts and uses of databases 

 Understand the different types of databases 

 Start Access 2010 

 Open an existing database 

 Understand the database window and database objects 

 Open a database table 

 Identify parts of a table 

 Navigate through records in a table 

 Manipulate data in a table by filtering and sorting records 

 Add a new record to a table 

 Delete a record from a table 

 Close a database table 

 Close a database 

 Exit Access 

Section 

1 
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What is a Database?   
A database is an organised collection of information on a specific subject.  We use databases all 
the time in everyday life – the telephone directory, for example, is a database. 

Other examples of databases could be: 

 Recipe book 

 List of employee details (start date, name, address, date of birth, salary) 

 List of CD collection (name of CD, date of release, artist/band) 

 Stock listing (product name, number of stock, supplier, type of product) 

 Library (where all the books are categorised and then stored alphabetically within the 
category making them easy to find) 

The data in an Access 2010 database is stored in one or more tables.  A table is made up of 
records, and records are made up of fields.  In a Customers table, a record could be: 

Smith Jane 319 Alfred St East Sydney NSW 2010 (02) 9955 2523 

The fields could be called: 

Surname FirstName Street Suburb State PostCode PhoneNumber 

 

Uses of Databases 
Databases hold information.  This information can be searched and selected. 

For example: 

 A telephone directory is used to search for the telephone number of a person whose name is 
known to you.  You already know the contents of the Surname field, and usually the 
FirstName field – these are your search criteria. 

 The search criteria are then used to look up the additional information about the person – i.e. 
to find the particular record and therefore the address and telephone number of the person. 

 If you only know one criterion value (e.g. the Surname), you will find many more matching 
records than if you know more criteria (e.g. the Surname, FirstName and StreetAddress). 

 

Advantages of Databases 
Databases are designed to store large amounts of data.   They allow you to control the way the data 
is organised and displayed. 

Once the required information has been stored in a database, it can be used in many ways.  For 
example, you can format and print it as a report.  Charts can also be created using information in 
the database. 

Examples of database programs other than Access 2010 are Lotus Approach, DataEase, and Dbase 
IV. 
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Different Types of Databases Models 
There are several different types of Database Models: Flat File, Relational, Hierarchical, and 
Network models.  Each is briefly described here. 
 
Flat File Data Model (Single Table)  

This data model stores data in a single table in rows and columns.  There are no links to any other 
sources of data. Data stored in a single Excel spreadsheet is an example of a flat file database. 

If only one table is used for a database all data will be stored in and accessed from that table.  This 
is an example of a Flat File Database. 

Clients’ Pet Visits 
ClientID Title FirstName LastName Address PetName PetType VisitDate Reason 
Andrw1 Mrs  Judy  Andrews 2 Ocean View Rd Lassie dog 30/11/2005 Injury 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Matthew cat 22/11/2005 Illness 
Robbn1 Dr Jonathan  Robbins 122 Crowley Court Tippy bird 19/11/2005 Illness 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Jennifer bird 18/11/2005 Injury 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Matthew cat 11/11/2005 Routine 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Matthew cat 03/11/2005 Illness 
Andrw1 Mrs  Judy  Andrews 2 Ocean View Rd Zachary dog 02/11/2005 Illness 

 
You will notice that data duplication occurs in this Flat File Data Model.  For example:  

a) Mr Bill Evans’s name and address appears in each of his records. 

b) He has two pets, a cat and a bird and has visited the Vet several times with these pets. 
Their names and types are also duplicated. 

Data duplication is a problem with the Flat File Data Model, and this increases the chances of it 
being entered incorrectly. 

Relational Data Model (Multiple Tables) 

Data in this model is stored in multiple tables, each on a specific subject.  Sometimes you will 
want to combine data from two or more tables, and this requires that Relationships have been 
created between them. 

If we took the single table example above and converted it into a relational database, we would 
split the data into three separate tables.  This would remove the problem of duplication of data. 

The diagram below shows an example of relationships between tables. 
 Clients Visits Pets 
 

 

 

 

 
The tables would appear as shown on the following page.  Each table is storing data on a specific 
topic.  The tables are related by a common field: Clients and Visits by ClientID, and Pets and 
Visits by PetID. 

PetID 
PetName 
PetType 
PetGender 

ClientID 
PetID 
VisitDate 
Reason 
Treatment 

ClientID 
Title 
FirstName 
LastName 
Address 
Suburb 
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Clients Table 

ClientID Title FirstName LastName Address Suburb 
Evans1 Mr  Bill  Evans 34 Hopetown Rd Takapuna 
Andrw1 Mrs  Judy  Andrews 2 Ocean View Rd Torbay 
Robbn1 Dr Jonathan  Robbins 122 Crowley Court Epsom 

Pets Table 
PetID PetName PetType PetGender 
1 Jennifer bird F 
2 Matthew cat M 
3 Lassie dog F 
4 Zachary dog M 
5 Tippy bird F 

Visits Table 
ClientID PetID VisitDate Reason Treatment 
Evans1 1 18/11/2005 Injury Bandage leg 
Evans1 2 03/11/2005 Illness Medication for cat fever 
Evans1 2 11/11/2005 Routine Full examination, no problems 
Evans1 2 22/11/2005 Illness Under observation 
Andrw1 3 30/11/2005 Injury Operation 
Andrw1 4 02/11/2005 Illness Injection for diarrhoea 
Robbn1 5 19/11/2005 Illness Ointment 

 
Hierarchical Data Model (Tree-like Structure)  

The Hierarchical model is organised in a tree-like structure.  This means it allows there to be 
repeating information in the data that uses parent/child relationships.  A parent/child relationship 
means that each parent may have many children but each child will only have one parent. 

Hierarchical Model Example 

 

 

 

 

 

 
If we were to use this on the Client and Pets example the Client is the Parent and the Pet is the 
Child.  Under a Hierarchical structure One Client may have many Pets, but each Pet may only 
have One Client (Owner). 
 
Network Data Model (Tree-like Structure)  

The Network Model uses objects and their relationships in a more flexible way.  The important 
thing about a Network Model is it is viewed as a graph using object types which are referred to as 
nodes and relationship types which are referred to as arcs.   

When you compare the hierarchical model with the tree structure which has one parent and many 
children records this model gives the flexibility of having multiple parent and child records which 
make up a graph type of structure.   

This model was used widely in the early years of computing.  However, as computer processing 
became faster, people began using the Relational Model in preference to the Network Data 
models. 

Client/Pets is Parent/Child  
(One Client/Many Pets) 
 

Pets/Visits is Parent/Child 
(One Pet/Many Visits) 
 

Client (Parent) 

Pets 

Visits 

Vet 

Operations 
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Starting Access 2010 
Exercise 1 

1 Click on the Start button  and hover the cursor on All Programs.  

A menu of all programs appears.  

2 If necessary scroll to the Microsoft Office folder, click on it, and select Microsoft Access 
2010 as shown below. 

 

When you have used Access 2010 once (or more) it will appear on your Start menu as 
shown below.   

You can just click on it to start Access. 

 

 

Note 

Start 
 button 
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Backstage View 
When you open Access 2010 you see Backstage view. The File tab on the left contains commands 
that help you manage your files, eg Save, Open, Print, New, etc. 

 

 
 

 
 
 

Parts of Backstage view include: 

File Tab  
The File tab replaces the Office Button in Access 2007 and the File menu in Access 2003. 

Quick Access Toolbar 
The Quick Access Toolbar is a useful feature for accessing your most frequently used commands.   

Available Templates Window 
From this section you can create a new Blank Database, create a database based on a custom 
template, or view some of Access 2010’s Featured Online Templates. 

Title Bar 
If you have a database open, the file name appears on the title bar.  (There is no file name shown in 
the above illustration because a database is not open.) 

Minimize, Maximize and Restore Down 
These buttons are used to reduce the main window to a button on the Taskbar 
(minimise) and increase the size of the main window (maximise).  When the window is 
maximised, the Maximize button will display as the Restore Down button.  

Close 

The Close button  shuts down Access 2010.  

Close 

Restore Down Minimize 

Microsoft 
Access Help 
(F1) 

Title Bar 

Featured 
Online 

Templates 

Quick Access 
Toolbar 

Available 
templates 

File tab 
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Microsoft Access Help 

Exercise 2 

1 Click on the Microsoft Access Help button  in the top right corner of the window to 
display the Access Help window.  

 
2 Browse the Table of Contents or type a specific topic into the Search Box above it and click 

on . 

3 Click on the Close button  to exit from Help. 
 

 

Opening a Database 
Exercise 3 

1 Click on  then click on .  The Open dialog box will display existing 
database files that are included with this book. 
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2 Click on MovieMaker Database. 

3 Click on . 

Access 2010 has improved security measures to protect your PC from viruses.  Many 
database files contain shortcut programs called macros that are designed to help the user work 
more efficiently.  A macro could also be a virus however and Access 2010 may try to warn 
you about this.  

Unless your security settings are already set to the lowest level, Access 2010 may display the 
following security warning when you click on Open. 

 
 

4 Click on  because the database is clear of viruses. 

The database is now enabled so it can be accessed and used. 
 

Security Settings 

To view your current security settings you can click the File tab and select  from the 
menu. In the Access Options dialog box click on Trust Center. 

 

It is essential that you ensure the security of your computer, by using and maintaining up-to-date 
anti-virus software. 

If you make changes click on OK, or click on Cancel. 
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MovieMaker Database 

The database that has been opened is a simple database designed to keep track of videos for a 
video shop. 

The MovieMaker Database can be used as follows: 

 To search for specific videos 

 To find a specific type of video, eg action, romance, comedy 

 To see in how many videos the lead role is played by a specific actor or actress 

 To search for a specific director 

 To see if a video is in the shop or on lease 

Before you start using this database you will add buttons to the Quick Access Toolbar for speedy 
use of common commands. 
 

 

Using the Quick Access Toolbar 
The Quick Access Toolbar is a useful feature for accessing your most frequently used commands.  
Commands can be added or removed, and the toolbar itself can be positioned either above or 
below the ribbon.  (In Access 2010 the ribbon can also be customised.) 
 

Quick Access Toolbar List 
Exercise 4 

1 Click on the Customize Quick Access Toolbar  to the right of the 
Quick Access Toolbar.  The Customize Quick Access Toolbar menu will 
be displayed. 

A tick is shown at the left of every option that displays presently on the 
Toolbar. 

2 Click on New to add it to the Quick Access Toolbar. 
3 Click on the  again and click on Open.   

4 Add the following options to the Toolbar using the same steps. 

Quick Print, Print Preview, Spelling  

 

Customise Quick Access Toolbar 
Some other useful options that are not on the Quick Access Toolbar list can be added using the 
following steps. 

Exercise 5 

1 Click on the Customize Quick Access Toolbar button  to the right of the Quick Access 
Toolbar and select More Commands… 

The Access Options dialog box will display, with the Customize option selected.  
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2 Click on the Choose Commands from:  and select All Commands.  The commands are 
listed in alphabetical order. 

3 In the list at the left, scroll down until the Close commands are displayed.  

4 Click on  then click on . 

5 Click on  then click on .  The two 
commands will be added to the Quick Access Toolbar list on the right of 
the Access Options dialog box as shown at the right. 

6 Click in the following option  

7 Click on  to save the changes to the Toolbar. 

The Quick Access Toolbar is now displayed between the document 
area and the ribbon as shown at the right. 

8 Click on the Customize Quick Access Toolbar button  again and select Show Above the 
Ribbon to restore the Quick Access Toolbar to the original position. 

 
The position in which you display the Quick Access Toolbar is entirely up to you.   

The commands that you have added in the above exercise will be used throughout the remainder of 
this book.  (You may wish to add other commands now, or as you work through the book.) 
 

Closing Access 2010 
Leave the MovieMaker Database open but when you want to close the database use the Close 

Database button on the Quick Access Toolbar or  on the File tab menu. 

In Access 2010, clicking on the Close Window button on the Quick Access Toolbar OR 
at the top right of the screen  will close Access down completely. You can also 

click on  at the bottom of the File Tab menu to close Access 2010. 

Note 
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The Database Window 
When a database is opened the ribbon will display at the top of the Access 2010 window and the 
Navigation Pane will open to show the Database Objects for that database.  

 
 

Ribbon 
The ribbon displays options in groups that can be used to format, modify text, manage records and 
sort and filter data. 

Navigation Pane 
The Navigation Pane can be used to access the database objects, eg the MovieMaker Database and 
its tables, forms, queries and reports. 

Database Objects 
The database objects are displayed in the Navigation Pane.  Double click on the type of object you 
wish to use, eg the table displayed above. 

Shutter Bar Open/Close Button 
The Shutter Bar Open/Close Button allows you to close the Navigation Pane.  Click on the button 
again to open the Navigation Pane. 

Home Tab  
When an object from the database is opened the Home tab will display on the ribbon.  
 

 
 
 
 
 
Icon Controls  

Several of the icons in the groups on the ribbons display a drop down arrow 
 at the right.  This arrow can be used to display a gallery or list of more 

options as shown at the right.  

Database Object Navigation 
Pane 

Ribbon 

Shutter Bar Open/Close button  

Views  
Group 

Clipboard  
Group 

Records  
Group 

Sort & Filter  
Group 

Window  
Group 

Find  
Group 

Text Formatting  
Group 
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