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Downloading Exercise Files 
Exercise files can be downloaded from the Cheryl Price web site as follows: 
 

 
 

1 In your web browser, type: www.cherylprice.co.nz 

2 Press Enter on the keyboard to display the Cheryl Price website. 

3 Click on the Resources tab as shown at the right. 

4 Click on  Easy Way – PivotTables and PivotCharts  

5 

Under the Exercise Files heading click on the underlined blue hyperlink , ie   

PivotTables and PivotCharts Excel 2010    Free Download 
The File Download dialog box will display.   

6 If you have Winzip use the following instructions otherwise move to step 7. 

 a   Click on  .    

 
b   Click on the  of the  button. 

 c  If My Documents folder is not displayed click on Set default unzip folder at the bottom of 
the list.  Ensure My Documents is selected then click on Select Folder . 

 d    Click on the  of the  button and click on the My Documents folder.  The files will 
be unzipped. 

7 Click on and ensure My Documents folder is displayed.  Click on  

8 

Click on Open Folder which will display My Documents folder.  Right click on the zipped 
exercise file and select Extract All. Click on Extract.  A folder will be created containing the 
exercise files.   

You will need to double click on this folder to use the exercise files in this book. Sa
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Exercise Files used in this book 
 
(Instructions are at the front of this book for downloading retrievable files from our web site.) 

 
 

Names of files 

Cavanagh Industries Organic Fo ds Co 3 

Home Ideas (Categories) 2 PC Sales – PivotChart 2 

Home Ideas (Categories) PC Sales – PivotChart 

Home Ideas PC Sales 2 

Mykas – Adelaide PC Sales 

Mykas – Brisbane PivotChart 2 

Mykas – Melbourne PivotTables 

Mykas – Sydney Real Estate Sales 

Organic Foods Co 2 Rep Sales 
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PivotTables 

 
 

 
 
 
 

 
Learning Outcomes 
 
At the end of this section you should be able to -  
 

 Summarise data with PivotTables 

 Understand the Pivot Cache 

 Group and Ungroup data in a PivotTable 

 Change the values calculated in a PivotTable 

 Use a PivotTable for data consolidation 

 Choose and apply a Style to a PivotTable 

 Change the PivotTable Layout 
 

 

Section 

1 
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 PivotTables 
A PivotTable is an interactive worksheet table that provides a method of summarising and 
grouping large amounts of data from an Excel List.  Data can be formatted, and summarised using 
various calculations.  A PivotTable is also referred to as a PivotTable Report. 

PivotTables are so called because row and column headings can be rotated around the data area to 
allow different views of the source data to be displayed.  The fields from the list are placed around 
the PivotTable skeleton to define how the summarised information is shown and calculated.  

When source data changes, the PivotTable can be updated. 

Excel List  
For the best results when creating a PivotTable your Excel List should have the following 
characteristics. 

• The first row contains the headers that identify the data in each column. 

• Each column (field) contains unique data. 

• Each row (record) contains one set of data for a single item. 

• There should be no blank cells in the list. 

The PC Sales workbook (which you will be using in the first exercise), is a good example of such 
a list. 
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Why Create a PivotTable? 
If you want to summarise data from an Excel List you could possibly use the automatic Subtotals 
feature.  For example, in the PC Sales workbook you could display Sales subtotals for each 
Region. 

You would first have to sort the data by Region, then apply the Subtotal feature (Data Tab, Outline 
Group).   

 

Using the automatically applied Outline you could show or hide data levels, but if you required 
subtotals based on other fields you would have to re-sort the list and apply the Subtotal feature 
again. 

When you summarise your data in a PivotTable, you can take different views of the data without 
having to recreate the table each time. 

Creating a PivotTable 
 

The Pivot Cache 
It is important to understand that when a PivotTable is created it is not directly linked to the data 
source. This is because when you begin the process, the first step that Excel takes is to create a 
duplicate copy of the data source and store it in a Pivot Cache.  This occurs every time you create 
a PivotTable from a data source, which automatically increases the file size and the amount of 
memory being used.   

When you make changes to the data source, this is not automatically reflected in the PivotTable.  
This is easily managed by refreshing the data. 

Efficient use of the pivot cache and how to refresh data is covered later in this section. 
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Exercise 1 

1 Open the workbook called PC Sales.   

2 Ensure the Database worksheet is displayed. 

3 With the cursor anywhere within the list, click on the Insert tab then on .   

The Create PivotTable dialog box is displayed. 

4 Ensure Select a table or range and New Worksheet options are selected and that the 
Table/Range is as shown below. 

 
5 Click on OK.   

A new sheet is inserted to the left of the Database worksheet (Sheet1); a PivotTable area is 
displayed, together with the PivotTable Field List Task Pane (at the right) and the PivotTable 
Tools, Options and Design tabs as shown below. 
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There are two ways in which a  PivotTable can be used and manipulated, ie - 

• Normal Layout as shown on the previous page. 

• Classic PivotTable Layout which displays a grid – fields displayed in the PivotTable Field List 
can be dragged onto the grid (see capture on next page). 

 
5 Change the PivotTable layout view to Classic PivotTable Layout as follows: 

a On the PivotTable Tools, Options tab click on .   

b Click on the Display tab.  

c Ensure a tick is displayed in this option:  

d Click on OK. 

 

This applies the Classic PivotTable layout to the current PivotTable only.  
The PivotTable area is displayed showing all the field areas in the PivotTable.  
The fields in the database are listed in the PivotTable Field List Task Pane at the right of the 
screen. 

 
 
PivotTable Location Notes 

When creating a PivotTable you specify where you want it located in the Create PivotTable dialog 
box.  The usual recommendation (which is the default option in the Create PivotTable dialog box) 
is that it is placed on a new worksheet. 

If you decide later that you want to move a PivotTable to a different location, follow these steps: 

1 Select a cell in the PivotTable. 

2 On the PivotTable Tools, Options tab click on .   

The Move PivotTable dialog box is displayed. 

 

3 Specify where you want the PivotTable moved to, then click on OK. 

Notes 
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PivotTable Organisation 
You specify the fields you want to include in the PivotTable by either dragging them to the 
appropriate area in the lower half of the Task Pane OR to the PivotTable area itself. 

 

 

The four areas that make up a PivotTable are described below (these are shown in the PivotTable 
area and also in the lower half of the PivotTable field list: 

Report Filter  
This contains the field(s) that control how the data is presented and how it can be filtered.  In 
effect, individual PivotTables are created for each possible value in the Report Filter Field as well 
as for all the values. 

For example, in PC Sales the Report Filter Field could be Year, which would produce three pivot 
tables: one for 2010, one for 2011, and one for both years combined.  Only one of these 
PivotTables is displayed at any given time, depending on which Report Filter Field value is 
selected.   

Similarly, if Region were specified as the Report Filter Field, the data for all regions or for 
individual regions could be displayed.  

Column Labels (Fields) 
Column Fields are used to create the horizontal axis of the PivotTable.  If more than one field is 
placed in the Column Labels area you should place them in descending order of importance.  For 
example, you would place Month below Year in the Column Labels box in the PivotTable Field 
List so that sub-totals for each month within each year could be created. 

Row Labels (Fields) 
Row Fields are used to create the Vertical Axis of the PivotTable.  You can place more than one 
field in the Row Labels area using the same method as described above for placing multiple 
Column Fields. 

Value Fields 
Field(s) placed in the Values area contain the data to be summarised using any of the available  
functions such as Sum, Average, etc.  A PivotTable must have at least one Values field.  
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Totals and Subtotals 

When a PivotTable is created, subtotals and grand totals are automatically generated.  These can 
be deleted or hidden if required. 
Because these totals are produced based on the data in the List, you should ensure that the List 
does not contain subtotals. 

Exercise 2 

The PivotTable will initially be set up to display the sales for all products for each salesperson 
within each region. 

1 Drag the Product field to the Report Filter area as shown below. 

 

2 Drag the Salesperson field to the Row Labels area. 

3 Drag the Region field to the Column Labels area. 

4 Drag the Sales field to the Values area. This will be labelled Sum of Sales – Sum is the 
default function.   

The fields are also displayed in the actual PivotTable area on your worksheet. 

If you are using the Classic PivotTable layout you can also drag the fields onto the 
appropriate section of the PivotTable area.  

If you place a field in the wrong area, simply drag it to the correct area.   

The PivotTable is displayed as shown on the next page. 

 

 

 

Drag the 
Product field 
from here 
down to the 
Report Filter 
area 

The Product field is now 
displayed in the PivotTable grid 
as shown below. 

Sa
m

pl
e D

oc
um

en
t



8    SECTION 1  Cherylprice.co.nz Limited 

 

5 Rename the worksheet PivotTable 1. 

6 Click on the Product (All)  in cell B1.   

The options shown below will be displayed. 

 

7 Select Hardware to view all hardware sales.  Click on OK.  

 

Notice that the down arrow button now shows as , indicating that the PivotTable is 
filtered. 

8 Click on the Product , select Software, and click on OK. 
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PivotTable Tools Contextual Tab 
When you select any cell in a PivotTable, the PivotTable Tools contextual tab is displayed on the 
ribbon.  It includes two tabs – Options and Design. 

The Options Tab 

 

The Options tab includes a wide range of options that allow you to modify calculations, apply 
sorting and filtering, update the table data, etc. 

The Design Tab 

 
The Design tab allows you to adjust the layout of the table, apply preset styles to the table, etc. 

The PivotTable Field List is also displayed whenever your active cell is within the PivotTable. 
 

Exercise 3 

 Click outside the PivotTable. The PivotTable Tools contextual tab and the PivotTable Field 
List are hidden. 

 

Displaying Report Filter Pages 
Individual PivotTables for each unique value in the report filter field can be created on separate 
sheets (pages) in the workbook. 

Exercise 4 

1 Select a cell in the table, click on the Product  in cell B1 and select (All).  

2 Click on OK. 

3 On the PivotTable Tools, Options tab, click on the   of the Options button in 
the PivotTable group.  Select . 

 
4 Click on OK.   

Sa
m

pl
e D

oc
um

en
t



10    SECTION 1  Cherylprice.co.nz Limited 

Two new worksheets will be inserted into the workbook, one for each Product category. 

 

5 Review the Hardware and Software worksheets, and then return to PivotTable 1. 
 

Changing the Layout 
In the following exercise the PivotTable layout will be changed to display the product sales for 
each salesperson with a subtotal for each salesperson. 

Exercise 5 

The lower half of the PivotTable Field List to reorganise the fields by dragging them from one box 
to another. 
 
1 Drag the Product field which is in the Report Filter box so it is under the 

Salesperson field in the Row Labels section of the Field List as shown at 
the right. 
  
The table will be displayed as follows. 

 

2 Rearrange the fields as shown below. 

 

The PivotTable is now displayed as shown on the next page. 
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3 Click on the Salesperson (All) , select Evans, then click on OK. 

4 Click on the Product (All) , select Software, then click on OK. 

 

5 For Salesperson and Product, select (All) then click on OK to display the report filter fields as 
shown below. 

 
6 If necessary, click in the PivotTable to show the PivotTable Field List. 

7 Rearrange the PivotTable as shown below.   

See if you can do this on your own – then look at the next page to see how the fields are 
positioned in each field box. 
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Removing a Field from a PivotTable 
Exercise 6 

 Click on  and drag it outside the table area until the pointer displays as      

 
When the mouse button is released the field and all its information will be removed. 

Alternative methods include unchecking the Year field in the 
PivotTable Field List OR clicking on the field name in the Row 
Labels box and selecting Remove Field as shown at the right. 

 

Viewing Detailed Data 
A PivotTable is a summary of information contained in a list.  However, there may be times when 
you wish to view the individual values that contribute to a particular total. 

Exercise 7 

1 Click on the Hardware sheet tab.  Ensure fields are displayed as shown at 
the right.  

2 Double click on cell C6 - Melbourne sales for Green. The following data is 
displayed on a new sheet. 

 
3 Delete the new sheet. 

Note 
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