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Downloading Exercise Files 
Exercise files can be downloaded from the Cheryl Price web site as follows: 
 

 

 

1 In your web browser, type: www.cherylprice.co.nz 

2 Press Enter on the keyboard to display the Cheryl Price website. 

3 Click on the Resources tab as shown at the right. 

4 Click on  Easy Way – Microsoft Excel 2010   

5 

Under the Exercise Files heading click on the underlined blue hyperlink , ie   

Excel 2010, Level 3    Free Download 
The File Download dialog box will display.   

6 If you have Winzip use the following instructions otherwise move to step 7. 

 a   Click on  .    

 
b   Click on the  of the  button. 

 c  If My Documents folder is not displayed click on Set default unzip folder at the bottom of 
the list.  Ensure My Documents is selected then click on Select Folder . 

 d    Click on the  of the  button and click on the My Documents folder.  The files will 
be unzipped. 

7 Click on and ensure My Documents folder is displayed.  Click on  

8 

Click on Open Folder which will display My Documents folder.  Right click on the zipped 
exercise file and select Extract All. Click on Extract.  A folder will be created containing the 
exercise files.   

You will need to double click on this folder to use the exercise files in this book. 
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Exercise Files used in this book 
 

(Instructions are at the front of this book for downloading retrievable files from our web site.) 
 

 

Names of files 

Auckland, Jan-Mar Mykas - Adelaide 
Balance Sheet Mykas - Brisbane 
Bonus Mykas - Melbourne 
Busy Bee Company Mykas - Sydney 
Charts - Classes November - Eats and Treats 
Charts - Cleantec Outdoor Life - October 
Charts - Goodwins PC Sales 
Classic Images Income PC Sales – Pivot Chart 
Company List PivotChart 2 
Computer Consumables Ltd PivotTables 
Cookery and Gardening Book Sales Real Estate Sales 
Corp1 Rep Sales 
Engineering Course Spartacus - Adelaide 
Exclusive Services – Quarterly Report Spartacus - Brisbane 
Fire Shop - Brisbane Spartacus - Melbourne 
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Fire Shop - Perth Sports Sales  
Fire Shop - Sydney Staff Listing 
Forms - Investment Calculator Supermarket 
Glen Miller - Writer Target Sales 
Gym Membership VitaHealth Products 
Hats Income Statement Wellington, Jan-Mar 
Investment Calculator Williams - Brisbane 
Kite Extreme Williams - Cairns 
Learning Cheques Williams – Canberra 
Lifestyle Images Products Williams - Sydney 
Loan Calculations  
Mid Semester Exam  
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Styles, Supplied Templates  
Hyperlinks, Linking Workbooks 
Outlines, Print Area, Data Consolidation 

 
 
 

 
Learning Outcomes 
 
At the end of this section you should be able to -  
 
 
 Modify and copy styles 

 Use and modify supplied templates 

 Insert and remove hyperlinks 

 Create and delete custom views 

 Use outlines to show and hide row and column data 

 Set up and clear a print area 

 Insert, adjust and remove page breaks 

 Consolidate data 

Section 
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Styles 
A style is a named set of formatting instructions that can be applied easily to text, values and 

formulas.  A style can be applied using  in the Styles group on the Home tab. There are many 
styles supplied with Excel, but you can also create your own. If the “properties” of a style are 
changed then all occurrences of that style will automatically be updated. 

Styles can be created: 

• By example – formatting is applied to a cell or group of cells which you then save as a style. 

• By defining the style using the  option on the  button. 

Exercise 1 

1 Start a new blank workbook. 

2 In cell A1 type: Susan then press Ctrl Enter. 

3 Change the Font Size to 24 pt, bold. 

4 Click on  and select  

5 In the Style dialog box type: Main Title as the Style name. 

6 Click on OK. 

The new style name can be seen by clicking on .  It is 
displayed at the top of the Style Gallery as a Custom style as 
shown at the right. 

 
7 A style will now be created called Totals.  This style will display a single line above the cell, 

a double line at the bottom of the cell and grey shading. The totals will display as currency 
with two decimal places and bold. 

a Click in an unformatted cell in the worksheet. 

b Click on  and select  

c Type: Totals in the Style name: box then click on . 

d On the Number tab select Currency, 2 decimal places and $. 

e Click on the Font tab and select Bold. 

f Click on the Border tab, then click on the Top Border 
button to apply a single line style as shown at the right. 

g Select a double line style from the Style: box.  Click on 
the Bottom Border button as shown at the right. 

h Click on the Fill tab and select a light grey colour. 

i Click on OK. 

Note 
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© Cherylprice.co.nz Ltd SECTION 1    3 

The style “properties” will be displayed in the Style dialog box shown below. 

 

8 Click on OK.  

The Totals style is displayed in the Styles Gallery as shown at the right. 

9 Use either method of creating a style (ie by example or using the Style dialog box) to add the 
following styles. 

Subtitle Calibri (Body) font, 14 pt, bold, italics 

Col Headings Calibri (Body) font, 11 pt, bold, centred, border top and bottom, grey 
shading 

All the styles you have created are displayed in the Styles Gallery on the  button as 
shown below. 

 

10 Click on the Select All button at the top left corner of the worksheet.  

11 On the Home tab click on  in the Editing group and select 
 as shown at the right. 

12 Create the following worksheet, using Sum functions in B10 and C10. 
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4    SECTION 1 © Cherylprice.co.nz Ltd 

13 Using the Style Gallery from the  button apply your custom styles as follows: 

a Select cell A1 and apply Main Title. 

b Select cell A2 and apply Subtitle. 

c Select cells A4 to C4 and apply Col Headings. 

d Select cells A10 to C10 and apply Totals. 

14 Select cells A6 to A8 and left align the product codes. 

15 Widen columns as necessary. 

 

16 Save as Abacus Ltd.   

The styles are saved with the workbook. 
 

 

Modifying a Style 
The properties of a style can be modified using Cell Styles. 

Exercise 2 

Change the Totals style font size to 12 pt as follows. 

1 Click on . 

2 In the Custom Styles area right click on Totals and select Modify…. 

3 Click on  in the Style dialog box. 

4 Click on the Font tab then on 12 in the Size: section.  Click on OK. 

5 Click on OK again.   

All cells to which this style has been applied are modified automatically.  Widen columns as 
required. 

6 Save the workbook. 
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© Cherylprice.co.nz Ltd SECTION 1    5 

Copying Styles to Another Workbook 
Any custom styles that you create can only be used in the workbook that you used to create them. 
If you want the styles to be available in another workbook, you must Merge the styles to that 
workbook. 

Exercise 3 

1 Ensure the Abacus Ltd workbook is open. 

2 Open the workbook called Computer Consumables Ltd. 

3 With the Computer Consumables Ltd workbook displayed, click on  and select 

. 

4 In the Merge styles from: box ensure Abacus Ltd is selected as shown below. 

 

5 Click on OK.  (Click on Yes if requested to merge styles that have the same names.) 

6 Practise applying styles in the Computer Consumables Ltd workbook as follows. 

• Cell A1 - apply the Main Title style. 

• Add a heading in cell A2 of Sales - January and 
apply the Subtitle style. 

• Cells A4 to C4 - apply Col Headings style. 

• Cell C14 - apply Totals style. 

7 Format cells C5 to C12 to display two decimal places. 

8 Save the workbook as Styles - Computer Consumables 
Ltd.  

9 Close both workbooks. 

When styles are modified or created and saved in a template they will be available in all 
workbooks based on that template. 

Applying the Normal style will remove all formatting from selected cells. 
Custom styles can be available to every workbook if they are stored in the default template 
book.xlt (see page 9). 
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Templates 

Using Supplied Templates 
Supplied templates are stored in the Templates folder. The normal pathname for this folder is 
C:\Users\Owner\AppData\Roaming\Microsoft\Templates.  If supplied templates are not installed 
Excel will install each individual template the first time it is selected.   

Exercise 4 

1 On the File tab click on . 

2 In the Available Templates – Office.com Templates section click on . 

3 Click on . 

4 With Basic Invoice selected click on  to open a new workbook with the template 
copied into it. The worksheet is shown below. 

  

Enter your own company 
details here 

Add customer 
information here 

Add details of the 
purchase quantity, 
description, unit price 

Edit information as 
required 
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© Cherylprice.co.nz Ltd SECTION 1    7 

5 Type the information below replacing the generic data. 

 

6 Click on the View tab then in the Headings check box to display row and column headings. 

7 Edit the Sales Tax Rate cell (B18) and change it to Goods and Services Tax:  Change the Rate 
in cell D18 to 15%, ie   

8 Right click on the Invoice Date cell (I9) and select .  
Click on Number then on Date.  Select the format shown at the right 
then click on OK. 

9 Delete text from cells H10 and I10, ie  

10 Delete the number from YOUR ORDER NO. cell I11, ie . 

11 Changed the SHIPPED VIA from Air to Courier (ie cell I14), ie  

12 Delete rows 15 and 16 which will remove the F.O.B. and PREPAID or COLLECT cells. 

13 Delete the data in the Quantity, Description and Unit Price columns. 

14 Edit the section at the bottom of the invoice as shown below. 

 
15 Click in the Invoice Number cell (I8), ie  .  Delete the invoice number 

and leave the cursor in that cell. 
16 On the File tab choose Save As, and select Excel Template from the Save as type: list. 
17 Type: Sparkle Invoice as the file name.  Save and close the template. 
 
 

Exercise 5 

1 On the File tab click on New.  Click on . 

2 Double click on Sparkle Invoice in the New dialog box. 

3 Fill in the information shown below (the date is entered automatically).  
Invoice No. 1001 
Sold To Paper Products 

35 Keith St  
Northcote  0627 

Your order No 408 
Sales Rep Max Cleary 

Qty Description Unit Price 
30 Boxes of Plain A4 Paper 55.00 (press Tab) 
5 Reams of Bright Yellow A4 Paper 8.00 (press Tab) 

4 Scroll down and you will notice that the Total and GST have been calculated automatically. 
5 Add Freight of 20.00. 
6 Save as an Excel Workbook with the name Sparkle Invoice 1001 and close it. 

Look at other templates to see how they can be amended and customised for your use. 
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Embedding Cell References in a Formula 
Exercise 6 

1 Open the workbooks Wellington, Jan-Mar and Auckland, Jan-Mar. 

2 Create a new workbook based on Exclusive Services - Quarterly Report template in the 
New from existing folder in Available Templates..  

The new workbook will be opened with the name Exclusive Services - Quarterly Report1 
displayed at the top of the screen. 

3 In cell B6 type: = 

4 On the View tab click on  and select Wellington, Jan-Mar 
as shown at the right, to switch to that workbook.  

5 Click in B9 and type: + 

6 Switch windows to Auckland, Jan-Mar. 

7 Click in B9 and press Ctrl Enter.  The calculation will display in the Formula bar as: 

 
The workbook name is in brackets, followed by the worksheet name, and then the absolute 
cell reference – for example, cell B9 of the Income Statement sheet in the Wellington, Jan-
Mar workbook. 

8 Delete the $ absolute reference indicators from the formula, and copy it to the February and 
March columns using the fill handle. 

9 Add similar formulas to cells B8:D8 to calculate Total Operating Expenses for the three 
months.   

 

The formulas in the Operating Income row have automatically recalculated. 

10 Save the workbook as Quarterly Report – Wellington, Auckland and close it. 

11 Close the remaining workbooks. Sa
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Updating Embedded Cell References  
Exercise 7 

1 Open the workbook Wellington, Jan-Mar. 

2 Change the Net Sales for February to $60,000.  Save and close. 

3 Open the Quarterly Report - Wellington, Auckland.  Click on  if 
required.  

The February Net Sales are now $98,000 and the Operating Income for February has 
increased to $41,988 as shown below. 

 

Because these cells are linked the results will change according to the changes in the attached 
workbooks. 

4 Save and close the Quarterly Report - Wellington, Auckland workbook.   
 

Creating a Default Template 

When you click on the New button  a new workbook will be created based on the default blank 
workbook template called book.xltx.   
 

Exercise 8 

1 Create a new blank workbook. 

2 On the Page Layout tab, click on the Page Setup Dialog Box Launcher   

3 Change the following settings using the tabs in the Page Setup dialog box. 
 

Tab Setting 

Page Orientation – Landscape: Paper Size - A4. 

Margins Change Top, Bottom, Left and Right Margins to 2 cm, Center on Page 
Horizontally and Vertically. 

Header/Footer Custom Header - Display the file name in the Centre section. 

Custom Footer – Display the Sheet name in the Left section and the Page number 
preceded by the word Page in the Right section. 

4 Click on OK. 
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5 On the File tab choose Save As.  

6 From the Save as type: list select Excel Template. 

7 Starting from C Drive navigate to the XLSTART folder as indicated below. 

 

8 Type: Book in the File name: box. The template will be called Book.xltx and saved in the 
XLSTART folder. 

9 Save and close the template. 

10 Click on the New button . 

11 Click on the Margins button in the Page Setup group and confirm that the four margins are 
now set to 2 cm. Click on the Orientation button to confirm Landscape orientation is set. 

12 Click on OK. 

13 Close the workbook without saving it. 
 

Deleting the Default Template 
To remove the Default Template you have specified, delete the Book template from the 
XLSTART folder as follows.  Excel will then revert to its original default settings. 
 

Exercise 9 

1 Ensure all workbooks are closed. 

2 Click on the Open button In the Open dialog box or Windows Explorer and locate the 
XLSTART folder. 

3 Select the Book template and delete it. 

4 Click on Yes to confirm the deletion, then close the dialog box. 
 

Exercise 10 

1 Open the workbook called Cookery and Gardening Book Sales. 

2 Delete the Production Target numbers (G8:G13), leaving formulas intact. 

3 Save the file as an Excel Template in the Templates folder with name Book Sales. 

4 Close the template. 
 

To use the template, select New on the File tab, click on My Templates, select the Book 
Sales template, then click on OK.  When the workbook has been completed save it with an 
appropriate workbook file name. 

Note 
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Consolidation Exercise 
Scenario 
Hillside College has mid semester exams for its students to assess their levels of Accuracy, 
Display, and Time Management.   

A workbook has been set up with the student information for your class and you will create 
formulas where grades can be used to assess overall results. 

 

Functions will be used to insert actual marks according to grades for 
students. 

A table has been created on a separate sheet to show marks for each grade.   

You will use a VLOOKUP function to enter the marks from this table.   

The Overall column will hold the total marks and a column chart will be 
created to display these results. 

An IF function will be used in the Final Result column to display the 
achievement category.  IF the mark is - 

>37 display Merit 
>25, <=37 display Pass 
<=25 display Fail 

The completed worksheet will appear as shown on the next page. 
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The COUNTIF function will be used to count the number of students in each achievement 
category.  This will be displayed in a Results section of the worksheet as shown here.  From this 
data you will create a pie chart.  Marks will then be changed and the pie chart will be updated. 

The charts will be linked to a Word memo and the linking between Excel and Word will be 
checked. 

It is important that ranges are named as instructed throughout these exercises, and formulas are 
checked thoroughly. 
 

Naming the Lookup Table 
Exercise 11 

1 Open the workbook called Mid Semester Exam. 
This workbook contains exam marks on Sheet1 and a table on Sheet2 that will be used to look 
up marks. 

2 Double click on the Sheet1 tab and type the name Exam Results. 

3 Rename Sheet2 as Lookup Table. 
You will assign a range name for the lookup table as follows. 

4 With the Lookup Table sheet displayed, select cells A2 to B16. 

5 Click in the Name box and type: lookup as shown below. Press Enter. 

 

6 Click on the Exam Results sheet tab. 

Name box 
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