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Word Reference 
 

 Word 2007 

Automatic Hyphenation 
 

1 Choose the Page Layout tab and click on . 

2 Select Automatic OR select Hyphenation Options and add a tick to 

the Automatically hyphenate document check box.  Change other 

options as required. 

3 Click on OK.   

Bold 1 Select text. 

2 Click on Bold  OR press Ctrl B  
 

Bullets 1 Click on the Bullets button . 

2 Select a bullet option from the drop down list OR select Define New 

Bullet from the list. 

To change the indent select the bulleted list, right click and select Adjust 

List Indents.  Change measurements as required (usually Bullet position is 

0 cm) then click on OK. 

Spacing can be adjusted by selecting the bulleted list, clicking on the 

Paragraph  and inserting for example 6 pt Spacing Before.  Ensure no 

tick is displayed in the Don’t add space between paragraphs of the same 

style check box.  Click on OK. 

Cenering (Horizontal) 1 Select text. 

2 Click on Center  OR press Ctrl E  
 

Centring (Vertical) 1 Choose the Page Layout tab and click on the Page Setup . 

2 Click on the Layout tab. 

3 Click on the Vertical alignment: , select Center, then click on OK. 

(Justified alignment spreads text between top and bottom margins.) 

Centring Words in 

Boxes 

Create a text box as follows: 

1 Choose the Insert tab, click on  then select an option. 

2 Select the text (Ctrl A) and type the text required. 

3 Click on the Center button . 

Text can be typed in any shape by right clicking on the drawn object and 

selecting Add Text. 

The Tables feature can also be used for boxes. 

Check Boxes 
1 Choose the Insert tab and click on . 

2 Click on a symbol or click on . 

3 Click on the Font: , scroll down and select Wingdings2 font. 

4 Click on the check box style desired, eg , click on Insert then Close. 

5 Select the box and change the font size to enlarge or reduce the box. 
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 Word 2007 

Date  1 Choose the Insert tab and click on . 

2 Select the date style required. 

3 Click on OK. 

(If Update automatically is ticked the date will be updated to the day of 

printing). 

Fonts, Font Sizes 1 Select text to be formatted. 

2 Choose the Home tab, click on the Font  in the Font group, and select 

the required font OR press Ctrl Shift F. 

3 Click on the Font Size  in the Font group OR Ctrl Shift P. 

4 Select the required size. 

Fonts and font sizes can also be changed by clicking on the Font . 

Grammar Check Word automatically shows incorrect grammar with a green wiggly line under 

it.  Right click to show suggestions.   

Choose the Review tab and select Spelling & Grammar. In the Spelling and 

Grammar dialog box incorrect words are shown in green text with 

suggestions. 

 To turn off grammar checking during spell check click on  

to remove the tick.  
 

Hard Space Ctrl Shift Spacebar 

Headers and Footers 
1 Choose the Insert tab and click on .  Select a Header text option 

(The header will be displayed). 

2 Type the text required in the header. 

3 To add a footer, click on  and select a Footer text option (The footer 

will be displayed). 

4 To move between the Header and Footer click on  OR  from the 

Design tab of the Header & Footer Tools. 

5 Click on  to close the Header or Footer OR double click in the 

document. 

Indent  

(Left Margin Only) 

1 Click on the Increase Indent button  OR press Ctrl M. 

2 Type in the text and press . 

3 On the next line click on the Decrease Indent button  OR press Ctrl 

Shift M. 
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Indent  

(Left and Right Margins) 
1 Click on the Paragraph . 

2 In the Indentation section, type the same measurement for Right and Left 

indents, eg 1.27 cm. 

3 Click on OK then type the text.   

4 Press Enter. 

5 Press Ctrl Q to return to normal paragraph. 

Alternatively you could drag the left and right indent markers on the ruler. 

  
 

Indenting to a  

Specified Position 
Drag the Hanging Indent marker  across the ruler to the indent position. 

Alternatively you can select the Hanging Indent button  from the Tab 

Type button and click on the ruler. 

OR 

1 Set a tab where text is to wrap back to in the last column. 

2 Before moving across to the last column press Ctrl T and text will wrap 

back to this point on the second and subsequent lines. 

3 When finished, on the line underneath press Ctrl Q. 

Inserting Files 1 Position the cursor where the file is to be inserted. 

2 Choose the Insert tab and click on . 

3 Double click on the file to be inserted. 

Italics 
1 Select text. 

2 Click on Italic  OR press Ctrl I. 
 

Line Spacing Select the text then click on the  of the Line Spacing button  and 

select the required option. 

The following shortcut keys can be used: 

1.5 spacing Ctrl 5 (Top Row) 

Double spacing Ctrl 2 “ 

Single spacing Ctrl 1 “ 
 

Line spacing can also be changed in the Paragraph dialog box. 
 

Manual Hyphenation 
 

Use the following keys for manual hyphenation. 

Ordinary hyphen Hyphen key 

Soft hyphen Ctrl Hyphen 

Hard hyphen  Ctrl Shift Hyphen 

 

Left Margin Indent              Right Margin Indent 
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Margins 1 Choose the Page Layout tab. 

2 Click on .   

3 Select an option from the list. 

OR 
 

1 Select  from the bottom of the list. 

2 Type measurements in the Left: and Right: boxes then click on OK. 

Margins can also be changed by dragging on the margin dividing line on 

the rulers.  When you rest the mouse there a double headed arrow will 

display.   

Note:  In Word margins are changed for the entire document (or section). 

Moving/Copying 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1 Select text to be moved/copied. 

2 Click on  OR   

3 Place the cursor in position to retrieve text. 

4 Click on the  button. 

Shortcut Keys 

Moving 

1 Select text and press Ctrl X. 

2 Move the cursor to the position where you want the text to be moved 

to. 

3 Press Ctrl V. 

Copying 

1 Select text and press Ctrl C. 

2 Move the cursor to the position where you want to copy text. 

3 Press Ctrl V. 

Drag and Drop 

1 Select text. 

2 Move mouse pointer into selected text and drag to new position (hold 

down the Ctrl key to copy). 

Windows Clipboard 

When items are cut/copied to the Windows Clipboard each item is 

replaced.  Up to 24 items however can be stored on the Clipboard.   

The Clipboard can be displayed by using the following steps. 

1 On the Home tab click on the Clipboard . 

The Clipboard task pane will display at the left of the document.  

Each time an item is cut or copied it will be displayed on the 

Clipboard. 

2 To paste a single item move to where it is to be pasted and click on it 

on the Clipboard. 

3 All items in the Clipboard can be pasted by clicking on . 

4 Clear the Clipboard by clicking on .  

5 Close the Clipboard task pane by click on the Close button . 
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Multilevel Numbering  1 On the Home tab click on the Multilevel List button  from 

the Paragraph group.  The List Library will display the numbering 

styles. 

2 Click on the style of numbering you wish to use. 

3 Click on OK.  (The first number will be inserted.) 

4 Type text for the first paragraph then press   

 To go in a level click on Increase Indent . 

 To go back a level click on Decrease Indent . 

 To skip numbering, with your cursor at the beginning of the paragraph 

press the Backspace key. 

 To continue numbering again click on the Numbering button (you 

may need to click on the Decrease Indent button). 

 To end numbering, press  twice OR press Ctrl Q on the next line. 

The numbering style and indents for each level can be modified by 

selecting the numbered text, then clicking on the Multilevel Numbering 

button.  Select  and change options as required.  

Click on OK. 

Spacing can be adjusted by selecting the multilevel list, clicking on the 

Paragraph  and inserting for example 6 pt Spacing Before.  Ensure no 

tick is displayed in the Don’t add space between paragraphs of the same 

style check box.  Click on OK.  

Page Borders 1 Place your cursor on the page where the border is required. 

2 Choose the Page Layout tab and click on   

3 Select the page border required. 

The Options button can be used to specify measurements of the 

border from the outside of the page etc. 

4 Click on OK. 

Page Breaks Press Ctrl  OR choose the Insert tab, click on  then select 

Page. 

Page Numbers 

1 Choose the Page Layout tab then click on   

2 Select Top or Bottom of Page. 

3 Select an option from the list. 

The page number will be inserted into the header or footer. 

To change the format or starting number select  

from the bottom of the Page Number button.  Change options as required 

then click on OK. 
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Paragraph Numbering Click on the Numbering button  to start numbering paragraphs. 

When you press  the next number will be inserted.   

 To skip numbering place the cursor at the beginning of a numbered 

paragraph and press the Backspace key. 

 To continue numbering again click on the Numbering button. 

 To end numbering, press  twice or press Ctrl Q on the next line. 

 The numbering style can be modified by clicking on  of the 

Numbering button   and selecting a new style from the list  

OR select Define New Number Format and customise the numbering 

accordingly. 

 A new starting number can be specified by selecting Set Numbering 

Value from the Numbering button list. 

 Spacing can be adjusted by selecting the numbered list, clicking on 

the Paragraph  and inserting, for example 6 pt Spacing Before.   

Ensure no tick is displayed in the Don’t add space between 

paragraphs of the same style check box.  Click on OK. 

Paragraph Spacing Choose the Page Layout tab and change measurements in the Spacing 

Before: and After: boxes 

OR change options in the Paragraph dialog box.   

For bullets, numbering and multilevel numbering ensure no tick is 

displayed in the Don’t add space between paragraphs of the same style 

check box. 

Pivoting  

(Flush Right Margin) 
1 Set a right aligned tab close to the right margin. 

2 Type text required at the left margin then press the Tab key.   

3 Type the text required at the right margin. 

If no text is required at the left margin click on the Align Text Right 

button  OR press Ctrl R. 

Sorting First name and Last name must be typed in using separate tabs or separate 

columns in a table. 

1 Select text to be sorted. 

2 On the Home tab click on the Sort button . 

3 Specify if the text has a heading row. 

4 Choose options required, eg ascending order. 

5 Click on OK. 

Spell Check A red wiggly line appears under spelling errors.  Right click on the word 

and choose the correct word from the list of options.  

From the Review tab use  to spell check a document or selected text. 

Options can be changed through the Office button, Word Options and 

click on Proofing. 
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Symbols 
1 Choose the Insert tab and click on . 

2 Click on a symbol, eg.  and it will be inserted into the document. 

You can click on and select a font, eg Wingdings 

for more choices. 

Synonyms To specify another meaning for a word, right click on the word then 

move the mouse pointer down to Synonyms.  Select a word from the list 

displayed at the right. 

Tabs 1 Select the tab type, left, centred, right or decimal, from the Tab Type 

button  at the left of the ruler. 

2 Click on the ruler to set the tabs. 

 Tabs can be removed by dragging the tab off the ruler OR by 

pressing Ctrl Q on the next line. 

 Tabs can be adjusted by selecting the text and moving tabs on the 

ruler. 

Tabs can be set left, centred, right or decimal.  Leader dots can be inserted up to a tab stop (see below) 

Tabs are set according to their position, eg  

 

L C D R 

Apples One 1,456.80 .........................1,234.25 
Bananas Fifteen 345.65 ............................. 23.90 

As a general rule, use left aligned tabs for text columns and right aligned tabs for numeric columns. 

Tabs with Leaders 1 Set tabs as required. 

2 Double click on a tab on the ruler to open the Tabs dialog box. 

3 Click on the tab measurement in the Tab stop position: box that the 

leaders are to go across to. 

4 Click in the Leader circle of the type desired. 

5 Click on Set then on OK. 

Text Alignment The following keys apply to the current paragraph that the cursor is in: 

Select text then for -  

Left alignment, click on Align Text Left  or press Ctrl L 

Centred alignment, click on Center  or press Ctrl E 

Right alignment, click on Align Text Right  or press Ctrl R. 

Justified alignment, click on Justify  or press Ctrl J. 
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Thesaurus 1 Place the cursor within the word. 

2 Choose the Review tab and click on  OR press Shift F7. 

The Research task pane will be displayed at the right of the screen. 

3 Click on the  next to the chosen word and select Insert. 
 

Underline 1 Select text. 

2 Click on Underline  OR press Ctrl U  
 

Word Count The number of words in the document will be displayed on the Status Bar.  

Text can also be selected and words displayed, for example . 

Alternatively,  

1 Select text if desired then choose the Review tab. 

2 Click on . 

3 Click on Close. 

 
 


